Closed Bug 1560703 Opened 1 year ago Closed 1 year ago

regression: No longer possible to disable FTP (network.ftp.enabled;false is without effect)

Categories

(Core :: Networking, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: darkspirit, Assigned: valentin)

References

(Regression, )

Details

(Keywords: nightly-community, regression, Whiteboard: [necko-triaged])

Attachments

(1 file)

mozregression --good 2019-01-01 --bad 2019-06-21 --pref network.ftp.enabled:false -a ftp://ftp.de.debian.org/

11:45.27 INFO: Last good revision: 7e7f893e8020efe2c40ce8da58d810bd218ec8bf
11:45.27 INFO: First bad revision: ec6db16dbb4e13293183548f1e2d3e367b63b316
11:45.27 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7e7f893e8020efe2c40ce8da58d810bd218ec8bf&tochange=ec6db16dbb4e13293183548f1e2d3e367b63b316

Flags: needinfo?(valentin.gosu)

Regarding checking if loading ftp:// is allowed: Could a reimplementation cover bug 1496725 as well?

See Also: → 1496725
Assignee: nobody → valentin.gosu
Flags: needinfo?(valentin.gosu)
Priority: -- → P1
Whiteboard: [necko-triaged]

Previously we would throw in nsFtpProtocolHandler::NewURI. Since that doesn't exist anymore, and creating FTP URLs always works, we need to make sure creating the FTP channel doesn't work anymore.

Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/51b4af33ce0d
Make sure creating an FTP channel throws if FTP is disabled r=michal
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.