Closed Bug 1560776 Opened 9 months ago Closed 9 months ago

Pixelated/garbage window contents after snapping window in GNOME

Categories

(Core :: Graphics: WebRender, defect, P3)

57 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- affected

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Steps to reproduce:

  1. Login to a Wayland session of GNOME
  2. Start Firefox
  3. Use Windows+left or right to snap window

What happens:

Window becomes pixelated

Expected result:

Window contents are readable.

Firefox is running under XWayland, not Wayland.

24:04.38 INFO: No more inbound revisions, bisection finished.
24:04.38 INFO: Last good revision: d4f9f1628d1f5fe3a5f461c760a0a7eac5027171
24:04.38 INFO: First bad revision: 757d5565859254a998fb14c73ebd403648345638
24:04.38 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d4f9f1628d1f5fe3a5f461c760a0a7eac5027171&tochange=757d5565859254a998fb14c73ebd403648345638

Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Linux
Regressed by: 1557265

Wayland backend is recently disabled in nighly, see Bug 1560545. Looks like you switched to X11 Firefox version which is broken. This looks like a problem with HW acceleration/GFX drivers, can you try to disable webrender/gl compositor? Thanks.

Flags: needinfo?(yoasif)
Priority: -- → P3

I don't see the corruption if I disable WebRender.

Flags: needinfo?(yoasif)
Component: Widget: Gtk → Graphics: WebRender

Can you attach your about:support please? Thanks.

Flags: needinfo?(yoasif)

about:support attached.

Flags: needinfo?(yoasif)

Marking this invalid; I downgraded my alpha graphics drivers from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers and the issue isn't reproducible.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → INVALID
See Also: → 1569745
You need to log in before you can comment on or make changes to this bug.