Add proper "CFBundleURLTypes" to Info.plist

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: devnull, Assigned: saari)

Tracking

Details

(Reporter)

Description

17 years ago
Both OmniWeb and Internet Explorer have vastly different "CFBundleURLTypes" in
their Info.plists.

Their format is as follows:
<key>CFBundleURLTypes</key>
<array>
  <dict>
    <key>CFBundleURLName</key>
    <string>http URL</string>
    <key>CFBundleURLSchemes</key>
    <array>
      <string>http</string>
    </array>
</dict>
</array>

The format in Navigator is:
<key>CFBundleURLTypes</key>
<array>
  <dict>
    <key>CFBundleURLIconFile</key>
    <string>fileBookmark.icns</string>
    <key>CFBundleURLName</key>
    <string>Web Location</string>
    <key>CFBundleURLSchemes</key>
    <array>
      <string>http</string>
      <string>https</string>
    </array>
  </dict>
</array>

I'm not sure if this is a major problem but having it consistant with the "true"
cocoa browser couldn't hurt, as well as the big browser, in fact this might also
allow Chimera to be retained by System Preferences as the default browser
instead of having reversions.

Comment 1

17 years ago
James, do you know of any actual bugs caused by Chimera's present Info.plist?

The reversions are caused because IE is hardcoded into the system, and when the
system can't find Chimera any more for some reason it just reverts to IE. There
are docs out on the web with instructions on modifying the system default browser.

Comment 2

17 years ago
I don't see a problem here. The CFBundleURLName entry is probably just for
display somewhere. Navigatgor has a CFBundleURLIconFile entry for icons, which
is fine. And we have the appropriate protocols listed under.CFBundleURLSchemes
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.