Closed Bug 1560840 Opened 5 months ago Closed 5 months ago

Perma [Tier 2] TEST-UNEXPECTED-PASS | /service-workers/service-worker/unregister.https.html | Unregister twice - expected FAIL

Categories

(Core :: DOM: Service Workers, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=253059550&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/C-oKmK9RSjOQybFVFDMXsg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-24T04:50:50.209Z] 04:50:50 INFO - TEST-OK | /service-workers/service-worker/unregister-then-register.https.html | took 1261ms
[task 2019-06-24T04:50:50.210Z] 04:50:50 INFO - TEST-START | /service-workers/service-worker/unregister.https.html
[task 2019-06-24T04:50:50.210Z] 04:50:50 INFO - Closing window 2147485012
[task 2019-06-24T04:50:50.529Z] 04:50:50 INFO -
[task 2019-06-24T04:50:50.529Z] 04:50:50 INFO - TEST-UNEXPECTED-PASS | /service-workers/service-worker/unregister.https.html | Unregister twice - expected FAIL
[task 2019-06-24T04:50:50.529Z] 04:50:50 INFO - TEST-INFO | expected FAIL
[task 2019-06-24T04:50:50.750Z] 04:50:50 INFO - .
[task 2019-06-24T04:50:50.750Z] 04:50:50 INFO - TEST-OK | /service-workers/service-worker/unregister.https.html | took 543ms
[task 2019-06-24T04:50:51.398Z] 04:50:51 INFO - Closing logging queue
[task 2019-06-24T04:50:51.398Z] 04:50:51 INFO - queue closed
[task 2019-06-24T04:50:51.418Z] 04:50:51 INFO - Setting up ssl
[task 2019-06-24T04:50:51.439Z] 04:50:51 INFO - certutil |
[task 2019-06-24T04:50:51.454Z] 04:50:51 INFO - certutil |
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO - certutil |
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO - Certificate Nickname Trust Attributes
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO - SSL,S/MIME,JAR/XPI
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO -
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO - web-platform-tests CT,,
[task 2019-06-24T04:50:51.470Z] 04:50:51 INFO -
[task 2019-06-24T04:50:53.225Z] 04:50:53 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-06-24T04:50:54.475Z] 04:50:54 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_PROCESS_LOG=/tmp/tmpRdRHZmpidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --ez use_multiprocess True --es env10 R_LOG_LEVEL=6
[task 2019-06-24T04:50:56.018Z] 04:50:56 INFO - Starting runner
[task 2019-06-24T04:50:56.250Z] 04:50:56 INFO - TEST-START | /service-workers/service-worker/update-after-navigation-fetch-event.https.html
[task 2019-06-24T04:50:56.257Z] 04:50:56 INFO - Setting pref dom.serviceWorkers.enabled (true)
[task 2019-06-24T04:50:56.278Z] 04:50:56 INFO - Setting pref javascript.options.streams (true)

Hello Graham,
This seems to be caused by the changes in Bug 1558851, could you please look into it?

Flags: needinfo?(james)
Regressed by: 1558851
Flags: needinfo?(james) → needinfo?(mjzffr)
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8348ffde2e8f
Revert wpt-sync metadata update for service-workers/service-worker/unregister.https.html; a=testonly
Flags: needinfo?(mjzffr)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.