Closed Bug 1560865 Opened 1 year ago Closed 4 months ago

Manage Cookies and Site Data not able to clear cookies created on file: (or potentially other URIs that don't have an origin we understand)

Categories

(Toolkit :: Data Sanitization, defect, P3)

67 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1565998

People

(Reporter: laurens, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Settings > Privacy
Manage Cookies and Site Data>Manage Data...
if the site name is blank/empty then the confirmation dialog box keeps popping up, cookies are not deleted.

Expected results:

the selected cookies should be delete, even if site name is blank.

(In reply to laurens from comment #0)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Settings > Privacy
Manage Cookies and Site Data>Manage Data...
if the site name is blank/empty then the confirmation dialog box keeps popping up, cookies are not deleted.

You mean you have data in that dialog where there is no content in the "Site" column? If not that, what do you mean by "the site name is blank/empty" ?

If that is indeed what you mean, the issue is that there shouldn't be any data in this dialog that has no associated site... if you open the settings, then open the browser console (ctrl-shift-j, not the regular developer console), clear its contents, and then open the manage cookies and site data dialog, do any messages appear in the browser console?

Expected results:

the selected cookies should be delete, even if site name is blank.

Flags: needinfo?(laurens)

Correct - the Site column was empty, but there was data.
When the selection of Sites cookies to delete included a site with a blank "Site" (name) entry then deletion could not be performed.

I ended up just removing everything - (clear all) and that worked, but partial deletion would not work.
Don't know if this might be a privacy issue, if an entry with an empty Site name can be forced to create such a cookie.

Flags: needinfo?(laurens)

Ah, hm. This is unfortunate because we will need a way to get into the same situation in order to test this.

Johann, I don't suppose we could end up in this situation maybe if there is data stored from a null principal'd document somehow?

Flags: needinfo?(jhofmann)
Component: Preferences → Data Sanitization
Product: Firefox → Toolkit

In case you have suggested steps for further investigation, we have another report of a blank/missing host name on SUMO: https://support.mozilla.org/questions/1264791

(In reply to jscher2000 from comment #4)

In case you have suggested steps for further investigation, we have another report of a blank/missing host name on SUMO: https://support.mozilla.org/questions/1264791

Can you ask them to bring up the "manage data" dialog, and then bring up the browser console (ctrl-shift-j - note, not the standard devtools console, the browser/privileged one!), clear it, and then try to select the cookies in question and delete them, and report back any errors that appear in the browser console ?

More generally, if they know what created those cookies that'd be helpful... bug 1565998 has one way (cookies from files on disk) but I'm able to delete such cookies (at least in nightly), so I expect there is another way of doing this...

Flags: needinfo?(jscher2000)
See Also: → 1565998

The user provided this from the Browser Console (the first line seems to be triggered by opening an in-content dialog):

Discarding onCreatedNavigationTarget for 17: received source tab data without any created tab data available
Stylesheets without CSSOM changes reparsed to check for errors. Refresh the page to also see errors from stylesheets changed from CSSOM and from style attributes. 4
stylesheets actor: fetch failed for chrome://browser/content/preferences/siteDataSettings.css, using system principal instead. stylesheets.js:219:13
Stylesheets without CSSOM changes reparsed to check for errors. Refresh the page to also see errors from stylesheets changed from CSSOM and from style attributes. 2
Unknown property 'user-select'. Declaration dropped. reps.css:23:15
Stylesheets without CSSOM changes reparsed to check for errors. Refresh the page to also see errors from stylesheets changed from CSSOM and from style attributes.
Error: Failed to fetch chrome://browser/content/preferences/siteDataSettings.css. Code 2152857618. DevToolsUtils.js:544:16


I tested with a page on file:// that creates a couple cookies. Manage Data has:

<richlistitem host="" selected="true" current="true">
  <hbox>
    <hbox class="item-box" flex="4" tooltiptext=""><label crop="end" value=""/></hbox>
    <hbox class="item-box" flex="1" tooltiptext="2"><label crop="end" value="2"/></hbox>
    <hbox class="item-box" flex="2"><label crop="end"/></hbox>
    <hbox class="item-box" flex="2" tooltiptext="7/18/2019, 7:47 AM"><label crop="end" value="1 hour ago"/></hbox>
  </hbox>
</richlistitem>

I can't inspect Save Changes.

If there is a blank-host entry in the list in Save Changes, clicking Remove closes the overlay but doesn't remove the cookies or close the Manage Data dialog.

Thanks! I was just wrong in commenting we can remove these entries - it looks like it works, but it doesn't actually...

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jscher2000)
Summary: Manage Cookies and Site Data not working → Manage Cookies and Site Data not able to clear cookies created on file: (or potentially other URIs that don't have an origin we understand)
Blocks: 1102808
Flags: needinfo?(jhofmann)
Priority: -- → P3

Fixed in bug 1565998

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1565998
See Also: 1565998
You need to log in before you can comment on or make changes to this bug.