Closed Bug 1560977 Opened 3 months ago Closed 3 months ago

Fission-enabled profiles should be clearly marked on crash-stats

Categories

(Core :: DOM: Content Processes, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
mozilla69
Fission Milestone M4
Tracking Status
firefox69 --- verified

People

(Reporter: Nika, Assigned: mccr8)

References

Details

Attachments

(2 files)

Fission is enabled by setting the useRemoteSubframes bit on a nsILoadContext. The easiest way to do this currently is by setting the fission.autostart pref.
We should clearly mark crashes in profiles which have set this bit as fission-enabled.

Fission Milestone: --- → M4
Priority: -- → P2
Assignee: nobody → continuation
Status: NEW → ASSIGNED

I've also got a data collection review thing that I'll upload after I get some feedback from Nika.

Attached file datareview.txt
Attachment #9075395 - Flags: data-review?(chutten)
Comment on attachment 9075395 [details]
datareview.txt

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is a Crash Annotation so is documented in its definitions file [CrashAnnotations.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/crashreporter/CrashAnnotations.yaml).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is part of crash reports so can be controlled through Firefox's Preferences for crash reports.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Nika Layzell is responsible.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction. (We could argue that it's Category 1 because the value of the pref at the time of a crash is more technical than interaction, but let's leave it at Category 2 because that's what the request asked for)

    Is the data collection request for default-on or default-off?

Default off. The user must opt-in to sending crash reports.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.

---
Result: datareview+
Attachment #9075395 - Flags: data-review?(chutten) → data-review+
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc9b37d2e954
Annotate crash reports if Fission is enabled. r=nika
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1561011
Flags: qe-verify+
QA Contact: vlad.lucaci

Comparing two different crashes encountered with fission enabled:

  1. Encountered before this fix -> bp-d3edca6f-7830-4980-ae4c-a1b320190619 (The DOMFissionEnabled is not displayed)
  2. Encountered after this fix -> bp-40090b34-f6c0-442f-97d0-da1d20190820 (The DOMFissionEnabled is successfully displayed and has the value of 1)

Marking this as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.