bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mozilla crashed, if the <form>- start tag is between <tr> and <td>

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Roman Joost, Assigned: rods (gone))

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [debian], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615
Debian/1.0.0-3
BuildID:    20020615

If i write the <form> tag between 
 <tr> and <td>, the mozilla crashed. I tried a little bit, to see what happened,
when i write the tag elsewhere. 

Reproducible: Always
Steps to Reproduce:
1. look at the given url. I fixed the page at
http://www.romanofski.de/Home/mails.htm
2. just try to write the HTML as described above


Actual Results:  the browser crashed

Expected Results:  don't render the table or render the table correctly. I don't
know if the first code is w3c correct.

I found out, that this code, wouldn't crash the browser:
<tr>
<td width="24%"> <form method="post" action="/cgi-bin/mail.home.cgi">

and this code will crash the browser:
<tr> <form method="post" action="/cgi-bin/mail.home.cgi">
<td width="24%">

Comment 1

16 years ago
wfm using build 2002070604 on Win2k and Linux (trunk).
Can you post Talkback ID for this crash 'mozilla/bin/components/talkback/talkback' ?
Do you mean you crash when Mozilla render the page or do you use Composer to
edit the page ?
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Mozilla crashed when it render the page. I edit the page with gvim. 
Sorry, but i can't post a talkback id, because i use the debian build. I think
the debian number things should be usefull: Mozilla 1.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615 Debian/1.0.0-3

and:
Mozilla Debian Package 1.0.0-3 (unstable)

Comment 3

16 years ago
1.0 release crashes, but
current trunk works
current branch works.

mark.annand: please try a recent build

Comment 4

16 years ago
sorry... not mark.annand... Roman Joost.
(Assignee)

Comment 5

16 years ago
need testcase, I mocked up a small example and it didn't crash.
(Reporter)

Comment 6

16 years ago
Look at the following URL: my Mozilla vers. crashed
http://www.romanofski.de/Home/mailold.htm. I tried the Alpha Release today and
the bug seems to be fixed.

Comment 7

16 years ago
marking worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.