Closed Bug 156105 Opened 18 years ago Closed 18 years ago

Ctrl-N and Ctrl-T should create clone of current page and history

Categories

(Core :: DOM: Navigation, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 18808

People

(Reporter: axel, Assigned: radha)

Details

Sometimes, I find myself on a web page and think "Now I would really like to
have the previous page in a separate window/tab to compare".
The most natural thing to do then would be Ctrl-N or Ctrl-T and hit the Back
button. But it doesn't work, since new windows/tabs start out with empty histories.

I request a new feature: new windows and tabs should start out with the history
of their parent, and should also start out displaying the parent's page. In
other words: Ctrl-N and Ctrl-T should clone the current window and state completely.
Severity: normal → enhancement

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.