Closed Bug 1561089 Opened 5 months ago Closed 5 months ago

Fission: http://twitter.com/ does not redirect to https if you are not logged in

Categories

(Core :: Networking, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla69
Fission Milestone M4
Tracking Status
firefox69 --- disabled

People

(Reporter: darkspirit, Assigned: valentin)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, Whiteboard: [necko-triaged])

Attachments

(2 files)

Debian Testing, KDE, X11

STR:
Launch

Actual: http://twitter.com/login is open.
Expected: We should be redirected to https://twitter.com/login.

Blocks: fission-dogfooding
No longer blocks: fission
Component: Untriaged → Networking
Product: Firefox → Core

What do you think, Valentin?

Flags: needinfo?(valentin.gosu)

So, I looked into it, and the https redirect actually happens and delivers the data to the correct process, but for some reason we end up with the wrong URL in the URL bar.
I've figured out that if we don't set the originalURI on the redirected channel, this problem no longer happens, but it seems odd to set it, since it was a redirected channel. Maybe we should treat it as a completely new channel?

In any case, I'm not yet sure if the bug is in Necko code or in the docshell.
Nika, do you know if the docshell does something with the originalURI from the document http channel that might cause this bug?

Flags: needinfo?(valentin.gosu) → needinfo?(nika)

Thanks to Honza we figured out that the resultPrincipalURI is not properly set on the loadInfo.
I'll land a patch ASAP.

Assignee: nobody → valentin.gosu
Flags: needinfo?(nika)
Priority: -- → P1
Whiteboard: [necko-triaged]
Duplicate of this bug: 1560214
Duplicate of this bug: 1562059
Duplicate of this bug: 1561108
Duplicate of this bug: 1559237
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0d7b68ec3e0a
The resultPrincipalURI needs to be set on the loadInfo used for the redirect r=mayhemer
Duplicate of this bug: 1552012
Blocks: 1562223
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Fission Milestone: ? → M4
You need to log in before you can comment on or make changes to this bug.