Closed Bug 1561102 Opened 1 year ago Closed 1 year ago

`mach vendor rust` fails with "Package mach has a non-approved license: BSD-2-Clause."

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Regression)

Details

Attachments

(2 files)

There are two problems:

  • the fact that mach is not whitelisted itself for BSD-2-Clause,
  • the fact that the error didn't show up when the crate was vendored in the first place

the fact that the error didn't show up when the crate was vendored in the first place

Turns out it does error out when I try backing out the vendoring from bug 1429847 and run mach vendor rust...

Assignee: nobody → mh+mozilla
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/021c05e47e6f
Add license exception for the mach crate. r=chmanchester
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Reopening for the second part.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/50b60c0b65c5
Add mach crate to license.html as well. r=froydnj
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.