Closed Bug 156133 Opened 19 years ago Closed 19 years ago

Linefeed in title attribute of any HTML tags is replaced with a strange char instead of adding a linefeed

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 67127

People

(Reporter: havarh, Assigned: attinasi)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0)
Gecko/20020530 MultiZilla/v1.1.17
BuildID:    2002053012

When using linefeeds in the title attribute of any HTML tags in Mozilla the
linefeed is replaced with a strange char, instead of adding a linefeed to the
tooltip.
Not sure if this also applies to the ALT attribute of IMG tags.
Example:
<a href="http://someurl.com" title="Go to a cool homepage:
URL: http://someurl.com">Cool Homepage</a>
or using JavaScript:
document.links[0].title="Go to a cool homepage:\nURL: http://someurl.com";


Reproducible: Always
Steps to Reproduce:
see above

Actual Results:  The linefeed char is replaced with a strange char

Expected Results:  the linefeed char should add a linefeed to the tooltip, and
all variants of CR/LF (Win/Mac/*nix) combinations should of course be treated as
one linefeed.
This is a dupe of either bug 47078 or bug 67127.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
QA Contact: petersen → amar
 Verified dupe of 67127
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.