Closed Bug 1561350 Opened 1 year ago Closed 1 year ago

bindgen libclang detection doesn't work for clang-cl 9

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: dmajor, Assigned: dmajor)

Details

Attachments

(1 file)

In the special pathsep codepath for clang-cl 9, I don't think the dirs variable is doing what was intended, because nothing reads it afterwards.

In the clang-cl 9 case where we have semicolon-separated paths, the dirs variable is never read, so the libclang detection fails.

Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dcf33acba095
Fix libclang detection for clang-cl 9 r=glandium
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.