Closed Bug 1561371 Opened 9 months ago Closed 9 months ago

Gmail on Android overflow intervention

Categories

(Web Compatibility :: Interventions, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: adamopenweb, Assigned: twisniewski)

References

()

Details

Attachments

(1 file)

When viewing emails on Gmail in Firefox Android it's not possible to scroll horizontally to view overflowing parts.

Suggested work around (should be verified):

.Sg {
    overflow-y: auto;
}

As per https://github.com/webcompat/web-bugs/issues/2983 this issue has been around since 2016.

Google has the bug on file but we have been waiting for some time to hear back. Maybe we should simply ship this intervention?

.Sg seems super prone to break, but maybe it's stable?

I just tested this on my phone, and it looks like the .Sg class isn't what's shown to me for all emails. There are both .Sg, and .Zg div elements right next to each other in the markup, and the .Zg is what gets the details in my case. I think we should be able to get away with this (which covers both, and anything else that ends up in their container):

body > #views> div {
  overflow: auto;
}
Attached file GitHub Pull Request

Linking Tom's PR for reference.

Assignee: nobody → twisniewski
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Depends on: 1562248
Regressions: 1581967
You need to log in before you can comment on or make changes to this bug.