Closed Bug 1561504 Opened 1 year ago Closed 1 year ago

[Mac] Launch the updater in place instead of copying it to the update directory

Categories

(Toolkit :: Application Update, task, P2)

Unspecified
macOS
task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: haik, Assigned: robert.strong.bugs)

Details

Attachments

(1 file)

On Mac, we might be able to avoid copying the updater.app out of Firefox.app and instead execute it in-place. This came up when working on bug 1556733. If we could avoid the copy, that would save some CPU cycles and it would be better because we wouldn't have to worry about whether or not the updater was quarantined.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Priority: -- → P3

Haik, I landed a patch to oak that doesn't copy the updater on Mac OS X. Could you try updating it on 10.15 and let me know if all is well? It should update to 70.a1. Thanks!
https://archive.mozilla.org/pub/firefox/nightly/2019/07/2019-07-05-23-40-50-oak/firefox-69.0a1.en-US.mac.dmg

Flags: needinfo?(haftandilian)

(In reply to Robert Strong (Away until 7/9) [:rstrong] (use needinfo to contact me) from comment #2)

Haik, I landed a patch to oak that doesn't copy the updater on Mac OS X.

Great!

Could you try updating it on 10.15 and let me know if all is well? It should update to 70.a1. Thanks!
https://archive.mozilla.org/pub/firefox/nightly/2019/07/2019-07-05-23-40-50-oak/firefox-69.0a1.en-US.mac.dmg

It seemed to work with no problems. I confirmed the version before and after updating. Tested on macOS 10.15 Beta 3 (19A501i).

Flags: needinfo?(haftandilian)
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Priority: P3 → P2
Summary: [Mac] Launch the updater in place instead of copying to the staging area → [Mac] Launch the updater in place instead of copying it to the update directory

This makes it so Mac OS X launches the updater inside of the bundle instead of copying to the update directory.
Cleans up some of the returns in nsUpdateDriver.cpp
Fixes the eslint no-useless-concat exceptions in the update tests

Thanks Haik!

Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ef7def8e867
Launch the updater in place instead of copying to the update directory on Mac OS X. r=bytesized
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Is this something we should consider backporting in the name of better support for 10.15, or can this ride the trains?

Flags: needinfo?(robert.strong.bugs)

This should be able to ride the trains since this shouldn't be needed with the fix in bug 1556733. If it were to be backported I'd prefer to let this hit beta first so there is a better chance of catching rare / unusual edge cases.

Flags: needinfo?(robert.strong.bugs)
You need to log in before you can comment on or make changes to this bug.