Closed Bug 1561519 Opened 2 years ago Closed 11 months ago

Cannot pause video on youtube in responsive design mode

Categories

(DevTools :: Responsive Design Mode, defect, P3)

defect

Tracking

(firefox67 affected, firefox68 affected, firefox69 affected)

VERIFIED FIXED
Tracking Status
firefox67 --- affected
firefox68 --- affected
firefox69 --- affected

People

(Reporter: alin.ilea, Unassigned)

References

(Blocks 1 open bug)

Details

Affected versions:
Nightly 69.0a1 (2019-06-25)

Affected platforms:
Windows 10, Mac OS 10.14 and Ubuntu 18.04

Prerequisites:

Access FF and enter in about:config
Type devtools.responsive.metaViewport.enabled and set the value to "true"
Steps:

  1. Open FF and access: https://www.youtube.com/
  2. Hit Ctrl + Shift + M in order to start Responsive Design Mode.
  3. Play a video.
  4. Switch to iPhone 6/7/8 and refresh the page.
  5. Try to pause the video.

Expected result:
Menu bar should appears and the user is able to pause the video by clicking on pause button or anywhere on the video.

Actual result:
Menu bar does not appears anytime when the user focus the video and cannot pause the video.

Notes:
The issue is reproducible only with touch simulation enabled.
The issue is reproducible on Galaxy S9/S9+, iPhone 6/7/8, iPhone 6/7/8+, iPhone X/XS.
Not reproducible on Responsive (if the user resize the viewport by drag it), iPad and Kindle.
Remember to refresh the page after each switch between devices.

I am able to reproduce the issue described above. I also tested this with Responsive, iPad and Kindle selected and can confirm this is not reproducible using those.

Thanks for filing this!

Priority: -- → P3

If this only happens with metaViewport ON, then we should probably also add the [rdm-reserve] whiteboard flag. Micah would you mind checking please?

Flags: needinfo?(mtigley)

(In reply to Patrick Brosset <:pbro> from comment #2)

If this only happens with metaViewport ON, then we should probably also add the [rdm-reserve] whiteboard flag. Micah would you mind checking please?

Hey Patrick, upon testing this again it seems this issue only happens when touch simulation is enabled, regardless of whether metaViewport is enabled or not. I'll change the bug to block the rdm-touch meta bug instead.

Flags: needinfo?(mtigley)
Blocks: rdm-touch
No longer blocks: rdm-meta-viewport

Tested again with Firefox nightly 71. The pause button appears, and I can click it. Clicking it temporarily pauses the video but then immediately goes back to playing.

Tested this in Firefox Nightly 77.0a1 (2020-04-16) (64-bit) . The issue appears to be fixed using the steps described by the reporter. I'll close the bug, but please feel free to re-open if this is not the case.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Hi,

I retested the issue in latest Nightly 77.0a1 (build id: 20200420214939) and it seems to be fixed.

Thanks.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.