Closed Bug 1561645 Opened 8 months ago Closed 8 months ago

Don't report origin telemetry on non-http or non-https documents

Categories

(Core :: Privacy: Anti-Tracking, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox69 --- verified

People

(Reporter: xeonchen, Assigned: xeonchen)

References

Details

Attachments

(1 file)

The "PAGELOAD" counter is affected by schemes such as "about" or "moz-extension", we should filter them out.

Pushed by xeonchen@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/eb74edb6c7ea
report only http/https schemes; r=baku
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Duplicate of this bug: 1561916
Flags: qe-verify+
Flags: needinfo?(ciprian.georgiu)

I can confirm that the origin telemetry is not countered for about:pages, on Firefox 69.0b5 (20190715173502) using Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64. Marking this bug as verified fixed.

Thanks Gary, for the hints provided in order to verify this patch.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(ciprian.georgiu)
You need to log in before you can comment on or make changes to this bug.