Closed Bug 1561660 Opened 1 year ago Closed 1 year ago

First run modal falls off the screen on some screen resolutions

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- verified
firefox70 --- verified

People

(Reporter: abenson, Assigned: emcminn)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: github-merged, regression)

Attachments

(5 files)

Attached image 04 join.PNG

We should decrease the top padding of the modal so that it is fully visible on the screen without having to scroll. As seen in the screenshot, the 'skip' call-to-action is not immediately visible.

Component: New Tab Page → Messaging System
Iteration: --- → 70.1 - Jul 8 - 21
Priority: -- → P2

For default screen resolution on Mac High Sierra 1440 x 900 - for localized text, start browsing button falls off the screen and when scrolled shows in white text.

To test set intl.l10n.pseudo config to accented

This issue is replicable and more prominent for lower resolution 1280 x800 and below in all locales

Looks like bug 1552195 added a max-height which makes the modal shrink for smaller screens but the content still wants the larger/static height.

https://github.com/mozilla/activity-stream/pull/5060/files#diff-fac216c1e95fcb028bddb101b2324ba7L23

Flags: needinfo?(emcminn)
Keywords: regression
Regressed by: 1552195
Assignee: nobody → emcminn
Flags: needinfo?(emcminn)
No longer blocks: trailhead-firstrun
Priority: P2 → P1

So this can be fixed by setting the overflow for the modal - what would the preferred behavior be? Do we want the overflowing content to be hidden, or do we want to be able to scroll the modal content to see the button on small resolutions?

Flags: needinfo?(edilee)

The previous behavior was to have the modal be the desired height and allow the user to scroll down. Sounds like aaron is suggesting we shift up the modal as well.

Flags: needinfo?(edilee)
Duplicate of this bug: 1563773
Blocks: 1565293
Status: NEW → RESOLVED
Closed: 1 year ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified that the issue is no longer reproducible on the latest Nightly 70.0a1 (Build ID 20190713215744) on Windows 10, macOS 10.14, and Arch Linux 14.4.3.
We're still going to have the "Start Browsing" button be under the view port on screen resolutions under 1000x800, but it's not cut off by the border.

Status: RESOLVED → VERIFIED

Is this something we should consider backporting to Beta or can this ride the trains?

Flags: needinfo?(emcminn)

What's your call on this one Aaron? Do we need to uplift

Flags: needinfo?(emcminn) → needinfo?(abenson)

Given that this occurs in one of our more common screen resolutions, I think we should uplift.

Flags: needinfo?(abenson)
Blocks: 1557298

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(emcminn)

Comment on attachment 9080183 [details]
Bug 1561660 - First run modal falls off the screen on some screen resolutions

Beta/Release Uplift Approval Request

  • User impact if declined: First run "submit" button will not be visible on some screen resolutions; impacts quality of a user's first experience with Firefox
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Go to about:welcome
  1. Try resizing the window to make it smaller vertically
  2. Ensure you are still able to see the submit button when scrolling / it's not cut off by the border
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small style-only change
  • String changes made/needed:
Attachment #9080183 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Flags: needinfo?(emcminn)
QA Whiteboard: [qa-triaged]

Comment on attachment 9080183 [details]
Bug 1561660 - First run modal falls off the screen on some screen resolutions

Fixes the first run "submit" button being cut off on some screen resolutions. Approved for 69.0b8.

Attachment #9080183 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that this issue is no longer reproducible with the latest Firefox Beta (69.0b8 Build ID - 20190725174626) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, the "Submit" button is still visible after browser resize.

You need to log in before you can comment on or make changes to this bug.