Closed Bug 1561731 Opened 2 years ago Closed 2 years ago

[10.15][Mac] libwidevinecdm.dylib can't be opened because it is from an unidentified developer

Categories

(Core :: Audio/Video: GMP, defect, P1)

67 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1558924

People

(Reporter: haik, Assigned: haik)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image widevinecdm-error.png

When trying to watch Netflix on macOS 10.15 Beta 2 with Firefox, a GateKeeper dialog is displayed (see attachment) stating "libwidevinecdm.dylib can't be opened because it is from an unidentified developer" and then the CDM crashes. As a result, Netflix is not usable with Firefox on 10.15.

This was first reported on bug 1556733 comment 31.

Like bug 1556733, this might be due to the changes in 10.15 regarding launching quarantined applications. I'm looking into this.

See the Apple WWDC presentation about quarantine changes in 10.15:
https://developer.apple.com/videos/play/wwdc2019/701/

Assignee: nobody → haftandilian
Blocks: catalina
Priority: -- → P1
See Also: → 1556733
See Also: → 1558924

After a change that disables quarantining of the downloaded CDM dylib, the CDM crash appears to be a EXC_BAD_INSTRUCTION crash in libdispatch.dylib`_firehose_task_buffer_init. More debugging needed.

Process 1898 stopped
* thread #1, queue = 'com.apple.main-thread', stop reason = EXC_BAD_INSTRUCTION (code=EXC_I386_INVOP, subcode=0x0)
    frame #0: 0x00007fff6982c752 libdispatch.dylib`_firehose_task_buffer_init + 266
libdispatch.dylib`_firehose_task_buffer_init:
->  0x7fff6982c752 <+266>: ud2    
    0x7fff6982c754 <+268>: cltq   
    0x7fff6982c756 <+270>: leaq   0x15020(%rip), %rcx       ; "BUG IN LIBDISPATCH: Unable to get the unique pid (size)"
    0x7fff6982c75d <+277>: movq   %rcx, 0x2d9929ac(%rip)    ; gCRAnnotations + 8
Target 0: (plugin-container) stopped.
(lldb) bt
* thread #1, queue = 'com.apple.main-thread', stop reason = EXC_BAD_INSTRUCTION (code=EXC_I386_INVOP, subcode=0x0)
  * frame #0: 0x00007fff6982c752 libdispatch.dylib`_firehose_task_buffer_init + 266
    frame #1: 0x00007fff6980c5fe libdispatch.dylib`_dispatch_client_callout + 8
    frame #2: 0x00007fff6980d776 libdispatch.dylib`_dispatch_once_callout + 20
    frame #3: 0x00007fff6982b415 libdispatch.dylib`voucher_activity_get_metadata_buffer + 100
    frame #4: 0x00007fff69a7fca5 libsystem_trace.dylib`_os_trace_init_slow + 94
    frame #5: 0x00007fff6980c5fe libdispatch.dylib`_dispatch_client_callout + 8
    frame #6: 0x00007fff6980d776 libdispatch.dylib`_dispatch_once_callout + 20
    frame #7: 0x00007fff69a7fbfb libsystem_trace.dylib`os_log_create + 784
    frame #8: 0x00007fff5fd322cd SkyLight`__SLSLogInit_block_invoke + 28
    frame #9: 0x00007fff6980c5fe libdispatch.dylib`_dispatch_client_callout + 8
    frame #10: 0x00007fff6980d776 libdispatch.dylib`_dispatch_once_callout + 20
    frame #11: 0x00007fff5fe0c606 SkyLight`__SLSInitialize_block_invoke + 375
    frame #12: 0x00007fff6980c5fe libdispatch.dylib`_dispatch_client_callout + 8
    frame #13: 0x00007fff6980d776 libdispatch.dylib`_dispatch_once_callout + 20
    frame #14: 0x00007fff5fcfc18d SkyLight`CGS_CHECK_INIT + 80
    frame #15: 0x00007fff5fe88b82 SkyLight`SLSGetOnlineDisplayList + 45
    frame #16: 0x00007fff5fec9111 SkyLight`SLGetOnlineDisplayList + 41
    frame #17: 0x0000000112d042d0 libwidevinecdm.dylib`___lldb_unnamed_symbol2520$$libwidevinecdm.dylib + 128
    frame #18: 0x0000000112d0414a libwidevinecdm.dylib`___lldb_unnamed_symbol2515$$libwidevinecdm.dylib + 26
    frame #19: 0x0000000112c84828 libwidevinecdm.dylib`___lldb_unnamed_symbol1099$$libwidevinecdm.dylib + 168
    frame #20: 0x0000000112cd1597 libwidevinecdm.dylib`___lldb_unnamed_symbol2156$$libwidevinecdm.dylib + 199
    frame #21: 0x000000010db6f70a XUL`___lldb_unnamed_symbol105639$$XUL + 554
    frame #22: 0x000000010bdfba76 XUL`___lldb_unnamed_symbol42938$$XUL + 5958
    frame #23: 0x000000010ba4f60f XUL`___lldb_unnamed_symbol32233$$XUL + 431
    frame #24: 0x000000010ba504c6 XUL`___lldb_unnamed_symbol32244$$XUL + 422
    frame #25: 0x000000010ba10e93 XUL`___lldb_unnamed_symbol31350$$XUL + 1971
    frame #26: 0x000000010ba11aba XUL`___lldb_unnamed_symbol31356$$XUL + 730
    frame #27: 0x000000010f902480 XUL`___lldb_unnamed_symbol171207$$XUL + 4128
    frame #28: 0x000000010a7c7f13 plugin-container`___lldb_unnamed_symbol1$$plugin-container + 99
    frame #29: 0x00007fff6985d3f9 libdyld.dylib`start + 1

Haik, watch out for the Widevine version changing in bug 1561693. It's on nightly as of about 3 hours ago.

(In reply to Nick Thomas [:nthomas] (UTC+12) from comment #2)

Haik, watch out for the Widevine version changing in bug 1561693. It's on nightly as of about 3 hours ago.

Thanks for the heads up! I'll make sure I have that version and retest. Closing this bug as a dupe of 1558924.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1558924
You need to log in before you can comment on or make changes to this bug.