mac osx: Can't define fonts for Hebrew

VERIFIED DUPLICATE of bug 110655

Status

()

--
major
VERIFIED DUPLICATE of bug 110655
17 years ago
17 years ago

People

(Reporter: ofer, Assigned: tetsuroy)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    1.0

When Working with MacOS X 10.2 (Jaguar built 6C87) the Hebrew font Preferences
definitions are close for editing.
This reflects the Hebrew URL's - you can't see hebrew in the right way !

Reproducible: Always
Steps to Reproduce:
1.install Jaguar 6C87
2.install Mozilla 1.0
3.Go to the Mozilla Preferencs - fonts
4. Switch to Hebrew
5. Try to define the fonts

Actual Results:  The font menu is locked for editing -As a result the URL's are
displaying incorrectly


Expected Results:  In Mac OS X 10.1.5 you can define the fonts.
By "locked for editing", do you mean disabled?

This would typially mean Mozilla can't find any Hebrew fonts on your system...

Comment 2

17 years ago
WorksForMe using FizzillaCFM/2002062203 on 10.1.5. Ofer, are you sure you have
Hebrew fonts installed and available on 10.2?

(This is Internationalization, not BiDi.)
Assignee: mkaply → yokoyama
Component: BiDi Hebrew & Arabic → Internationalization
Keywords: intl
QA Contact: zach → ruixu
Summary: Can't define fonts for Hebrew. → Can't define fonts for Hebrew
Is this a dupe of bug 110655?

Comment 4

17 years ago
if it is not a dupe of that bug, then it is a very similar relative. bug 153296
is probably related as well.
(Reporter)

Comment 5

17 years ago
Dear All !

The Mozilla was tested with the Jaguar native hebrew fonts
(Arial Hebrew, Peninim Hebrew, Corsiva Hebrew, Lucida Grand) +Additional
installed Hebrew fonts (all the Hebrew fonts are working with 10.1.5 & Mozilla)
I should say that all the fonts are installed & available by the system & other
Applications.
It seems to me that the hebrew fonts are NOT recognized by the mozilla browser.

Comment 6

17 years ago
just wondering: both for this bug and for  bug 110655 : Are the Hebrew fonts
installed directly in OSX, or are they taken from classic?
btw, the more I look at this bug, the more it looks like a dup of  bug 110655

Updated

17 years ago
Summary: Can't define fonts for Hebrew → mac osx: Can't define fonts for Hebrew
(Reporter)

Comment 7

17 years ago
The fonts are installed directly to the Mac OS X library/fonts.
After reviewing bug number 110655 it seems like the same bug But the browser
version is different & the system version is different

Comment 8

17 years ago
marking as dup per comment #7

*** This bug has been marked as a duplicate of 110655 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: ruixu → ylong

Comment 9

17 years ago
It sounds like dup of bug 110655 for me too.  Mark as verified.  You can re-open
if still see the problem after that bug fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.