Closed Bug 1561802 Opened 5 months ago Closed 5 months ago

Perma [Tier 2] /css/cssom-view/position-sticky-root-scroller-with-scroll-behavior.html | Sticky elements work with the root (document) scroller - assert_equals: expected 750 but got 749

Categories

(Core :: DOM: CSS Object Model, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed:patch])

Attachments

(1 file, 1 obsolete file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=253605499&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/AqKLOviMQYWeiXXs_zW5uA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-27T00:13:26.281Z] 00:13:26 INFO - TEST-START | /css/cssom-view/position-sticky-root-scroller-with-scroll-behavior.html
[task 2019-06-27T00:13:26.283Z] 00:13:26 INFO - Closing window 2147483858
[task 2019-06-27T00:13:27.733Z] 00:13:27 INFO -
[task 2019-06-27T00:13:27.733Z] 00:13:27 INFO - TEST-UNEXPECTED-FAIL | /css/cssom-view/position-sticky-root-scroller-with-scroll-behavior.html | Sticky elements work with the root (document) scroller - assert_equals: expected 750 but got 749
[task 2019-06-27T00:13:27.733Z] 00:13:27 INFO - @http://web-platform.test:8000/css/cssom-view/position-sticky-root-scroller-with-scroll-behavior.html:40:3
[task 2019-06-27T00:13:27.951Z] 00:13:27 INFO - TEST-OK | /css/cssom-view/position-sticky-root-scroller-with-scroll-behavior.html | took 1674ms
[task 2019-06-27T00:13:28.714Z] 00:13:28 INFO - Closing logging queue
[task 2019-06-27T00:13:28.714Z] 00:13:28 INFO - queue closed
[task 2019-06-27T00:13:28.723Z] 00:13:28 INFO - Setting up ssl
[task 2019-06-27T00:13:28.759Z] 00:13:28 INFO - certutil |
[task 2019-06-27T00:13:28.780Z] 00:13:28 INFO - certutil |
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO - certutil |
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO - Certificate Nickname Trust Attributes
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO - SSL,S/MIME,JAR/XPI
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO -
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO - web-platform-tests CT,,
[task 2019-06-27T00:13:28.801Z] 00:13:28 INFO -
[task 2019-06-27T00:13:30.582Z] 00:13:30 INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2019-06-27T00:13:32.044Z] 00:13:32 INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env9 MOZ_PROCESS_LOG=/tmp/tmp0tQZGupidlog --es env8 MOZ_CRASHREPORTER_NO_REPORT=1 --es args "-no-remote -profile /sdcard/tests/profile --marionette about:blank" --es env3 STYLO_THREADS=4 --es env2 MOZ_HIDE_RESULTS_TABLE=1 --es env1 R_LOG_VERBOSE=1 --es env0 MOZ_CRASHREPORTER=1 --es env7 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env6 R_LOG_DESTINATION=stderr --es env5 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env4 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --ez use_multiprocess True --es env10 R_LOG_LEVEL=6
[task 2019-06-27T00:13:34.209Z] 00:13:34 INFO - Starting runner
[task 2019-06-27T00:13:35.525Z] 00:13:35 INFO - TEST-START | /css/cssom-view/resize-event-on-initial-layout.html

Regressed by: 1560237

Hello Hiroyuki,
This failure seems to have started with your push of the changes in Bug 1560237, can you please take a look at it?

Flags: needinfo?(hikezoe)

Sure, I know the reason it's bug 1556685. Sigh, we should disable the test for now. :/

Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Flags: needinfo?(hikezoe)

These tests fail because of the layer alignment issue on GeckoView (bug 1556685).

Botond could you take a look at the patch?

Flags: needinfo?(botond)
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e4d773718202
Mark two test cases FAIL on Android E10S (i.e. GeckoView). r=botond

I went ahead and landed the patch as well.

Flags: needinfo?(botond)
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

(In reply to Botond Ballo [:botond] from comment #9)

I went ahead and landed the patch as well.

Thank you.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Whiteboard: [stockwell disable-recommended] → [stockwell fixed:patch]
Attachment #9074423 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.