Closed Bug 1561844 Opened 1 year ago Closed 1 year ago

Remove OpenH264 plugin from about:addons

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- verified
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: eliza.balazs, Assigned: andrei.a.lazar)

References

Details

(Whiteboard: [fennec68.1])

Attachments

(1 file, 1 obsolete file)

Environment:
Device: Nexus 6P (Android 8.1.0);

Build:
Nightly 68.0a1 (2019-06-25);
Nightly 69.0a1 (2019-06-26) from mozilla-central;
Beta 68.0b13;

Steps to reproduce:

  1. Launch Fennec and go to about:addons;
  2. Observe the Add-ons page options;

Expected result:
OpenH264 plugin should not be displayed due to Bug 1548679.

Actual result:
OpenH264 plugin is displayed on the Add-ons page.

Notes:

  • The functionality of the OpenH264 plugin option was removed in Bug 1548679 and this bug was created for removing it from the UI.
Assignee: nobody → vlad.baicu
Priority: -- → P1
Keywords: checkin-needed

Comment on attachment 9074503 [details]
Bug 1561844 - Disable and hide OpenH264 from about:addons. r=petru

Beta/Release Uplift Approval Request

  • User impact if declined: Bug 1548679 disabled this functionality but it is still visible in about:addons, creating a direct dependency on this issue.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open about:addons and check if OpenH264 is still visible.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is only changing the preference which controls if the OpenH264 plugin is visible and enabled.
  • String changes made/needed:
Attachment #9074503 - Flags: approval-mozilla-beta?
Flags: qe-verify+

We need to show this UI for users that still have Openh264 installed. For users that are new and do not have OpenH264 the UI should not appear.

The current patch is not acceptable as we cannot disable the UI for all users.

Keywords: checkin-needed
Attachment #9074503 - Flags: approval-mozilla-beta?
Flags: qe-verify+

My bad, I was under the impression that we want to remove it completely. I have canceled the landing of the patch and am looking further into how this can be achieved, thanks!

Assigning myself to this since Vlad fully booked with Fenix work.

Assignee: vlad.baicu → andrei.a.lazar
Attachment #9074503 - Attachment is obsolete: true

I think a good way to check if the plugin is available or not is to check if the plugin version number is set. If the plugin is not available the version number is $value$. Check bug 1548679 for more details.

Setting firefox-esr68=affected status flag because we want to track this for Fennec ESR 68.

Removed OpenH264 plugin from addons list for users that doesn't have it installed.

Keywords: checkin-needed

Pushed by opoprus@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bbe14fc96195
Remove OpenH264 plugin from about:addons r=VladBaicu

Keywords: checkin-needed

Fixed lint warnings.

Keywords: checkin-needed

Andrei, I think those eslint warnings were fixed by Noemi in comment 11.

Flags: needinfo?(andrei.a.lazar)
Keywords: checkin-needed

Sorry, we clashed in mid-air, mb.

Flags: needinfo?(andrei.a.lazar)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Andrei, we should uplift your about:addons fix to Fennec ESR 68.1 (and probably 69 Beta for consistency). We don't need this fix for the Fennec ESR 68.0.x dot release.

Flags: needinfo?(andrei.a.lazar)

Comment on attachment 9076517 [details]
Bug 1561844 Remove OpenH264 plugin from about:addons r=VladBaicu

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Users may still be able to see the disabled addon which may be confusing for some users.
  • User impact if declined: Bug 1548679 disabled this functionality but it is still visible in about:addons, creating a direct dependency on this issue.
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is only changing the preference which controls if the OpenH264 plugin is visible and enabled.
  • String or UUID changes made by this patch:
Flags: needinfo?(andrei.a.lazar)
Attachment #9076517 - Flags: approval-mozilla-esr68?

Comment on attachment 9076517 [details]
Bug 1561844 Remove OpenH264 plugin from about:addons r=VladBaicu

Improves a confusing UX situation for users without the OpenH264 plugin. Approved for Beta and Fennec 68.1b2.

Attachment #9076517 - Flags: approval-mozilla-esr68?
Attachment #9076517 - Flags: approval-mozilla-esr68+
Attachment #9076517 - Flags: approval-mozilla-beta+

Hi, the issue does not reproduce:
With devices for Fennec-ESR - Beta 68.1b2 - Build1:

  • Google Pixel (Android Q)
  • Sony Xperia Z3 (Android 5.1.1)
  • Huawei MediaPad M3 Lite 10 (Android 7)
  • Nexus 9 (Android 7.1.1)
  • Samsung Galaxy Tab S3 (Android 8)
    With device - Sony Xperia Z3 (Android 5.1.1) on Beta 69.0b5
    With device - Sony Xperia Z3 (Android 5.1.1) on Nightly 70.0a1(2019-07-16)

I will update the ticket as Verified

Whiteboard: [fennec68.1]

Hi, verified as fixed on Firefox 68.1 with Google Pixel 3 Xl (Android 9), Samsung Galaxy Note 9 (Android 8.1.0) and Sony Xperia Z5 (Android 7.0) with Firefox RC 68.1.
I will remove the whiteboard flag.

Whiteboard: [fennec68.1]
Whiteboard: [fennec68.1]
You need to log in before you can comment on or make changes to this bug.