Closed Bug 1561873 Opened 5 months ago Closed 3 months ago

Support for keyboard navigation in WS frame list.

Categories

(DevTools :: Netmonitor, enhancement, P3)

enhancement

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: Honza, Assigned: tanhengyeow)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

WebSockets frame list displayed in WebSockets side panel should support keyboard navigation.

At least the following keys should be supported

  • arrow key up
  • arrow key down
  • Home (move to the first)
  • End (move to the last)

Honza

Type: defect → enhancement
Depends on: 1559398
Priority: -- → P3
Summary: Support for keyword navigation in WS frame list. → Support for keyboard navigation in WS frame list.
Duplicate of this bug: 1565499

Support for keyboard navigation in WS frame list.

Assignee: nobody → E0032242
Status: NEW → ASSIGNED

Prototype that works for me:

  1. The patch is again using the PAGE_SIZE_ITEM_COUNT_RATIO. It's not nice, but good enough for now and the request list is using that too actually.

  2. It fixes also bug 1576078, so we might want to close that one as dup

Please apply and test

Honza

Flags: needinfo?(E0032242)
Duplicate of this bug: 1576078

Updated the patch!

Flags: needinfo?(E0032242)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ae73cf1c7395
Support for keyboard navigation in WS frame list. r=Honza

Backed out changeset ae73cf1c7395 (bug 1561873) for eslint failure at FrameListContent.js on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/598fa04e395e32634ccffc97bd7de7dae0497bdc

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=ae73cf1c7395dda33313fb7dbb56c8060be6174c&selectedJob=264286280

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264286280&repo=autoland&lineNumber=227

Log snippet:

[task 2019-08-30T17:09:45.849Z] building 'psutil._psutil_posix' extension
[task 2019-08-30T17:09:45.849Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_common.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
[task 2019-08-30T17:09:45.849Z] x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=543 -DPSUTIL_LINUX=1 -I/usr/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
[task 2019-08-30T17:09:45.849Z] x86_64-linux-gnu-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wl,-Bsymbolic-functions -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/psutil/_psutil_common.o build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o -o build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so
[task 2019-08-30T17:09:45.849Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
[task 2019-08-30T17:09:45.849Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2019-08-30T17:09:45.849Z]
[task 2019-08-30T17:09:45.849Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2019-08-30T17:22:17.213Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/devtools/client/netmonitor/src/components/websockets/FrameListContent.js:88:45 | 'frames' is assigned a value but never used. (no-unused-vars)
[taskcluster 2019-08-30 17:22:17.552Z] === Task Finished ===
[taskcluster 2019-08-30 17:22:18.554Z] Unsuccessful task run with exit code: 1 completed in 953.659 seconds

Flags: needinfo?(E0032242)

Fixed lint.

Flags: needinfo?(E0032242)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc2a5d551b3c
Support for keyboard navigation in WS frame list. r=Honza
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.