Closed Bug 1562050 Opened 9 months ago Closed 9 months ago

Quantum bar : cannot scroll searches after clicking show history button

Categories

(Firefox :: Address Bar, defect, P1)

Desktop
All
defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.4 - Jun 24 - Jul 7
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- verified
firefox67 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: pablo.muir, Assigned: adw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

[Description:]
In quantum bar, i cannot select any searches after clicking the show history button

[Environment:]
69.0a1 Nightly Ubuntu 18.04 / Macos 10.14.4 / Windows10 all affected
68.0b13 Beta Ubuntu 18.04 / Macos 10.14.4 / Windows10 all affected
67.0.4 Release not affected because quantum bar is turned off by default in about:config

[Steps:]
-Launch firefox with clean profile
-Open new tab, type www.youtube.com , hit enter
-Youtube site loads.
-With your mouse, click on the Down arrow (show history button, its hidden, you have to hover over it) (button is next to page actions / save to pocket/ bookmark)
-List of search suggestions appear
-Press down key on your keyboard

[Actual Result:]
On ubuntu: search suggestion sites appear, but if you press down key it scrolls the page
on Windows: search suggestion site appears, but if you press down key it does nothing
on MacOs: search suggestion site appears, but if you press down key it does nothing

[Expected Result:]
when you press show history button, the site should be highlighted, and then you press down key on keyboard you can navigate to one of the searches.

[Note:]
Since this does not reproduce with awesome-bar & Fx67, don't think it's a recent regression.
this happens with quantum bar, does not happen with awesome bar

(In reply to Pablo from comment #0)

on Windows: search suggestion site appears, but if you press down key it does nothing

It scrolls the page for me, also on Windows 10...

[Expected Result:]
when you press show history button, the site should be highlighted, and then you press down key on keyboard you can navigate to one of the searches.

Well, the site should not be preselected, but it should indeed highlight the first entry on DOWN.

Points: --- → 3
Component: Search → Address Bar
Keywords: regression
Regressed by: 1548031
Priority: -- → P3
Assignee: nobody → adw
Status: NEW → ASSIGNED
Points: 3 → 2

I don't really think this needs a test, but let me know if you think so.

Iteration: --- → 69.4 - Jun 24 - Jul 7
Points: 2 → 1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b180b228f558
Quantumbar: When the history dropmarker is clicked, focus the input. r=dao

If we want to fix this before release then this isn't a P3...

Blocks: quantumbar-input
No longer blocks: quantumbar-view
Priority: P3 → P1

It may be late for uplift to 68. Worth asking rel-man sooner than later. Please file the uplift request.

Flags: needinfo?(jcristau)

Yeah I figured this would just wait to 69 given how late in the cycle it is.

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Flags: qe-verify+

(In reply to Drew Willcoxon :adw from comment #7)

Yeah I figured this would just wait to 69 given how late in the cycle it is.

We should try to uplift, if possible, there's still 1 week before the merge. while it's not the best time to do it, the urlbar is important enough to work properly in most cases.

Flags: in-testsuite-
Attached patch Beta patchSplinter Review

Beta/Release Uplift Approval Request

  • User impact if declined: Quantumbar debuts in 68 so it would be nice to fix this for 68.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a one-line patch that just focuses the urlbar when the user clicks the dropdown arrow in the urlbar. There's not much risk that this will accidentally affect anything other than clicking the dropmarker. I've also tested the fix locally on Beta.
  • String changes made/needed: None
Attachment #9074823 - Flags: approval-mozilla-beta?

Hello!
Reproduced the issue using Firefox 69.0a1 (20190627214735) on Windows 10x64, macOS 10.14, Ubuntu 18.04.
The issue is verified fixed with Firefox 69.0a1 (20190630214222) on Windows10x64, macOS 10.14 and Ubuntu 18.04.

Comment on attachment 9074659 [details]
Bug 1562050 - Quantumbar: When the history dropmarker is clicked, focus the input.

quantumbar fix for 68.0 rc1

Flags: needinfo?(jcristau)
Attachment #9074659 - Flags: approval-mozilla-release+
Attachment #9074659 - Flags: approval-mozilla-esr68+
Attachment #9074823 - Flags: approval-mozilla-beta?

Hello,
The issue is verified fixed using Firefox 68.0 (20190701181138) on Windows 10x64, Ubuntu 18.04 and macOS 10.14.

QA Whiteboard: [qa-triaged]

Hi,
The issue is verified fixed using Firefox 68.0esr (20190704173630) on Windows 10x64, Ubuntu 18.04 and macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.