Closed Bug 1562115 Opened 5 months ago Closed 5 months ago

stub installer texts cut off for some locales or suboptimal vertically aligned

Categories

(Firefox :: Installer, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: aryx, Assigned: mhowell)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot of issue

Firefox 68.0b14 candidate 1 on Windows 8.1

The texts in the stub installer are longer for some locales which causes issues.

STUB_INSTALLING_HEADLINE has a forced linebreak.

STUB_INSTALLING_BODY often uses 4 lines for the text.

If both texts each use five lines, it will be cut off at the bottom. That's fixed for German but might also affect Russian:

https://transvision.mozfr.org/string/?entity=browser/installer/nsisstrings.properties:STUB_INSTALLING_HEADLINE&repo=gecko_strings
https://transvision.mozfr.org/string/?entity=browser/installer/nsisstrings.properties:STUB_INSTALLING_BODY&repo=gecko_strings

In general, there is some unused space available above the first string. Could the texts be moved up so the second one doesn't look crammed into the bottom left?

Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(a)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #0)

That's fixed for German but might also affect Russian:
Confirming that Russian is also affected.

The deadline to ship localization updates was two days ago (and that's why I push to have changes landed way before that).

I took an updated sign off for German, not sure I'll be able to take for Russian, given there won't be further builds before merge.

Having said that, this should be fixed in the installer, to make sure a longer localization can't overflow.

Flags: needinfo?(francesco.lodolo)

Hello everyone,
I've just downloaded Firefox Beta in Russian and as I see the strings aren't truncated.
Screenshot link: https://pp.userapi.com/c857624/v857624907/2460/UX_8jRXCAeE.jpg

Flags: needinfo?(a)

Issue of screenshot on Windows 8.1 with a device pixel ratio f 1.25.

(In reply to Francesco Lodolo [:flod] from comment #2)

The deadline to ship localization updates was two days ago (and that's why I push to have changes landed way before that).

I took an updated sign off for German, not sure I'll be able to take for Russian, given there won't be further builds before merge.

Having said that, this should be fixed in the installer, to make sure a longer localization can't overflow.

Thanks for the assist; I agree this is the installer's problem, I'll investigate.

Priority: -- → P1
Assignee: nobody → mhowell
Status: NEW → ASSIGNED

This patch copies over the same fix that was used for the profile cleanup page
to the installing page, since in some locales it can run into the same problem
of the header string being so long that it causes the next control to get cut
off by the bottom of the window.

Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da1d379db91d
Prevent cutting off long stub installer text strings. r=agashlin

Comment on attachment 9075225 [details]
Bug 1562115 - Prevent cutting off long stub installer text strings. r=agashlin

Beta/Release Uplift Approval Request

  • User impact if declined: Unreadable installer text in certain locales (maybe just ru, but could be others).
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Run a (release or beta) stub installer for an affected locale (such as ru) and verify that all text in the left column on the installing page fits within the window border.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a very focused cosmetic (text rendering) change that won't affect the installation process itself or have any effect on the majority of locales.
  • String changes made/needed:
Attachment #9075225 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9075225 [details]
Bug 1562115 - Prevent cutting off long stub installer text strings. r=agashlin

68 is in RC now, moving the approval request accordingly.

Attachment #9075225 - Flags: approval-mozilla-release?
Attachment #9075225 - Flags: approval-mozilla-esr68?
Attachment #9075225 - Flags: approval-mozilla-beta?

Comment on attachment 9075225 [details]
Bug 1562115 - Prevent cutting off long stub installer text strings. r=agashlin

stub installer regression fix, approved for 68 rc2

Attachment #9075225 - Flags: approval-mozilla-release?
Attachment #9075225 - Flags: approval-mozilla-release+
Attachment #9075225 - Flags: approval-mozilla-esr68?
Attachment #9075225 - Flags: approval-mozilla-esr68+

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Attached image Untitled.png

I managed to reproduce the issue using 68.0b14 on Windows 7 and Windows 8.1 by changing the size of the text and other items to Medium - 125% and using the DE build. Before Firefox 68.0b14, the DE strings were not translated.

I retested using Firefox 68.0 - build 2 on the same platforms and the issue is not reproducing with any of these locales: de, ja and ru.

However, the "Re-install" prompt is still affected when using the ru build. Please look at the attached image.

Flags: needinfo?(mhowell)

I can reproduce what comment 15 is showing even on Windows 10; I'm going to file a separate bug for it.

Flags: needinfo?(mhowell)
See Also: → 1566968
You need to log in before you can comment on or make changes to this bug.