Closed Bug 1562142 Opened 8 months ago Closed 8 months ago

8.58 - 9.84% raptor-speedometer-firefox/geckoview (Android, linux64-shippable, linux64-shippable-qr, windows10-64-shippable, windows10-64-shippable-qr, windows7-32-shippable) regression on push fbb26a04ec1f69879c85249da04fe3b971928ff0 (Thu June 27 2019)

Categories

(Core :: DOM: Core & HTML, defect, P1, critical)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 blocking fixed

People

(Reporter: igoldan, Assigned: heycam)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, regression, Whiteboard: [rca - Performance Error])

Raptor has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9b96152c5e6ecf97af63865f357e8106e0763ea4&tochange=fbb26a04ec1f69879c85249da04fe3b971928ff0

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

10% raptor-speedometer-firefox windows7-32-shippable opt 86.10 -> 77.62
10% raptor-speedometer-firefox linux64-shippable opt 90.92 -> 82.21
9% raptor-speedometer-geckoview android-hw-g5-7-0-arm7-api-16 pgo 9.79 -> 8.87
9% raptor-speedometer-firefox windows10-64-shippable opt 85.11 -> 77.17
9% raptor-speedometer-geckoview android-hw-p2-8-0-android-aarch64 pgo 24.78 -> 22.47
9% raptor-speedometer-firefox windows10-64-shippable-qr opt 85.45 -> 77.61
9% raptor-speedometer-firefox linux64-shippable-qr opt 89.86 -> 81.77
9% raptor-speedometer-geckoview android-hw-p2-8-0-android-aarch64 opt 22.38 -> 20.46

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=21627

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a Treeherder page showing the Raptor jobs in a pushlog format.

To learn more about the regressing test(s) or reproducing them, please see: https://wiki.mozilla.org/Performance_sheriffing/Raptor

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Component: General → DOM: Core & HTML
Product: Testing → Core
Flags: needinfo?(cam)

That is a pretty bad regression. Bug 1553705 should be probably backed out and then investigated why it causes this.

Backed out in bug 1553705 comment 11.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(cam)
Resolution: --- → FIXED
Assignee: nobody → cam
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → mozilla69

== Change summary for alert #21675 (as of Sat, 29 Jun 2019 20:03:31 GMT) ==

Improvements:

11% raptor-speedometer-geckoview android-hw-p2-8-0-android-aarch64 pgo 22.41 -> 24.83
11% raptor-speedometer-firefox linux64-shippable-qr opt 81.34 -> 89.96
10% raptor-speedometer-firefox linux64-shippable opt 82.28 -> 90.80
10% raptor-speedometer-firefox windows10-64-shippable-qr opt 77.82 -> 85.73
10% raptor-speedometer-geckoview android-hw-p2-8-0-android-aarch64 opt 20.49 -> 22.55
10% raptor-speedometer-firefox windows10-64-shippable opt 77.71 -> 85.38
10% raptor-speedometer-firefox windows7-32-shippable opt 80.57 -> 88.27
9% raptor-speedometer-geckoview android-hw-g5-7-0-arm7-api-16 pgo 8.89 -> 9.70
8% raptor-speedometer-firefox macosx1014-64-shippable opt 52.68 -> 56.94

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=21675

Status: RESOLVED → VERIFIED

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed
Flags: needinfo?(cam)

Hi tmaity, as requested I'd like to fill in the root cause here. From the spreadsheet, I think the closest category is "Performance Error", but there are no items in that category. What string should I use in the whiteboard? Is it [rca - Performance Error]?

Flags: needinfo?(cam) → needinfo?(tmaity)

(In reply to Cameron McCormack (:heycam) from comment #5)

Hi tmaity, as requested I'd like to fill in the root cause here. From the spreadsheet, I think the closest category is "Performance Error", but there are no items in that category. What string should I use in the whiteboard? Is it [rca - Performance Error]?

Hi Cameron, "Performance Error" is one of the root causes, there are no examples in that category, if you have any suggestions, please go ahead and add it. yes you can use [rca - Performance Error]`.

Flags: needinfo?(tmaity)

Thanks, I didn't realize that the items under each category were examples rather than strings to use in the whiteboard tag.

Keywords: rca-needed
Whiteboard: [rca - Performance Error]
You need to log in before you can comment on or make changes to this bug.