Closed Bug 1562205 Opened 5 months ago Closed 5 months ago

Perma TEST-UNEXPECTED-FAIL | remote/test/browser/browser_input_dispatchKeyEvent.js | Test timed out when Gecko 69 merges to Beta on 2019-07-01

Categories

(Remote Protocol :: Agent, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: malexandru, Assigned: jdescottes)

References

(Regression)

Details

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=253917119&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=05e1c33f877b884e4428c5ca8a4347bcf428fbdb&searchStr=%28remote%29

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=253917119&repo=try&lineNumber=1501

[task 2019-06-28T13:19:54.595Z] 13:19:54 INFO - TEST-PASS | remote/test/browser/browser_input_dispatchKeyEvent.js | The input caret has the correct index ("3"="3") -
[task 2019-06-28T13:19:54.595Z] 13:19:54 INFO - Send Left
[task 2019-06-28T13:19:54.599Z] 13:19:54 INFO - Send rawKeyDown for key ArrowLeft
[task 2019-06-28T13:19:54.600Z] 13:19:54 INFO - Send keyUp for key ArrowLeft
[task 2019-06-28T13:19:54.600Z] 13:19:54 INFO - Buffered messages finished
[task 2019-06-28T13:19:54.601Z] 13:19:54 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_input_dispatchKeyEvent.js | Test timed out -
[task 2019-06-28T13:19:54.601Z] 13:19:54 INFO - GECKO(1080) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 110: uncaught exception: Object
[task 2019-06-28T13:19:54.601Z] 13:19:54 INFO - GECKO(1080) | MEMORY STAT | vsize 20974904MB | residentFast 1030MB
[task 2019-06-28T13:19:54.605Z] 13:19:54 INFO - TEST-OK | remote/test/browser/browser_input_dispatchKeyEvent.js | took 90180ms
[task 2019-06-28T13:19:54.606Z] 13:19:54 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-06-28T13:19:54.606Z] 13:19:54 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/browser_input_dispatchKeyEvent.js | Found a tab after previous test timed out: data:text/html;charset=utf-8,<input type=text> -
[task 2019-06-28T13:19:54.609Z] 13:19:54 INFO - checking window state
[task 2019-06-28T13:19:54.610Z] 13:19:54 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 110}]
[task 2019-06-28T13:19:54.612Z] 13:19:54 INFO - TEST-START | remote/test/browser/browser_main_target.js

Julian, this seems to be regressed by Bug 1543142, can you please take a look at it?

Flags: needinfo?(jdescottes)

Sure, thanks for the ping.

It seems that the test times out when we wait for the "selectionchange" event after simulating an arrowLeft.
It turns out that listening to selectionchange on input is behind the pref dom.select_events.textcontrols.enabled , which is Nightly only.

I will force the pref in the test, that should fix the issue.

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Flags: needinfo?(jdescottes)
Priority: -- → P2

The test was relying on selectionchange events fired on an input text element.
This event is behind a pref, flip the pref to true during the test in order to make it
pass on all channels

Julian, the patch seems to work, can we get this landed on tree and merged into m-c before tomorrow's merge into beta? Thank you.

Flags: needinfo?(jdescottes)

I suppose I can land it without review since it's test only.
I don't see any other option since it's sunday.

Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/adc59d50adf8
Enable selectionchange on inputs for test browser_input_dispatchKeyEvent.js
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.