Closed Bug 1562253 Opened 5 months ago Closed 5 months ago

Uplift WebCompat 4.3.2 into beta

Categories

(Web Compatibility :: Interventions, enhancement)

enhancement
Not set

Tracking

(firefox-esr6868+ fixed, firefox68 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr68 68+ fixed
firefox68 --- fixed

People

(Reporter: denschub, Assigned: denschub)

References

Details

Attachments

(1 file, 1 obsolete file)

When bug 1562248 is done, let's get the entire 4.3.2 into beta. 4.3.2 will include important fixes for scrolling in GMail, some other -webkit-scrollbar fixes, as well as a intervention that addresses issues with video streaming sites using PDK 5.

As per Adam's decision, we want to have all of that in 68, so let's do that!

Is there a reason for not doing this as part of bug 1562248?

(In reply to Julien Cristau [:jcristau] from comment #1)

Is there a reason for not doing this as part of bug 1562248?

Yeah. Bug 1562248 is doing an 4.3.1 -> 4.3.2 update, but the beta version is a bit older than 4.3.0, because we landed some other things in Nightly as well. To me, it's wrong and confusing to to the uplift in that patch, as the uplift technically contains things that landed in central in three different bugs: bug 1562248, bug 1561299, and bug 1551672.

If you prefer having it mixed together in bug 1562248, I'm happy to do that, but my gut feeling was having a separate bug for that is a good idea.

I think it's a bit confusing either way but ok, we can keep this here. :)

Sorry. :) I knew this is a bit confusing, so I picked the to me least confusing way. Will check with you (or whoever is in charge then) next time we run into this situation to make sure it's clear for everyone!

Assignee: nobody → dschubert

Note that the patch is not meant to land in central - the code there is already landed in central. This patch was built for beta only and contains a set of patches as explained in comment #2.

Comment on attachment 9075162 [details]
Bug 1562253 - Uplift WebCompat system extension 4.3.2 into beta. r=miketaylr

(This uplift request is made on behalf of and after communicating with Adam Stevenson, who is on PTO now. :))

Beta/Release Uplift Approval Request

  • User impact if declined:
    • Scrolling issues on GMail for Firefox for Android users.
    • Video playback issues for Firefox for Android users on popular sites that use the PDK5 framework.
    • Minor visual glitches on other sites due to dependencies on -webkit-scrollbar.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Opting for a low risk, because we have experience in shipping interventions with similar logic. In the worst case, if the interventions contains errors or fails for other reason, the site would not break, but only the intervention would fail, so we can't make things more broken than they already are.
  • String changes made/needed:
Attachment #9075162 - Flags: approval-mozilla-beta?

Comment on attachment 9075162 [details]
Bug 1562253 - Uplift WebCompat system extension 4.3.2 into beta. r=miketaylr

approved for 68 rc1 (and esr68, but the flag isn't available)

Attachment #9075162 - Flags: approval-mozilla-beta? → approval-mozilla-release+
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.