Closed Bug 1562277 Opened 5 months ago Closed 4 months ago

Pocket New Tab - Revisit spoc dismissal flow

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox69 + verified
firefox70 --- verified

People

(Reporter: pdahiya, Assigned: thecount)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(2 files)

In discovery stream, dismissal of a spoc displays next spoc. Opening bug to evaluate if this annoys user running risk of turning off spoc stories and consider options
a) Alternate between showing a story and an ad
b) Display spoc story after a time delay
c) Not display spoc story in that session

https://github.com/mozilla/activity-stream/pull/5138#issuecomment-506822984

NI Wolasi for UX feedback

Flags: needinfo?(wkonu)
Component: Activity Streams: Newtab → New Tab Page

My recommendation would be to replace a dismissed spoc with a story if there is one for that session. I think that's the best experience from the user perspective.

Flags: needinfo?(wkonu)

+1 Wolasi. I think that would help serve content that is more relevant to readers

[Tracking Requested - why for this release]:
Before we launch the new layout with 7 rows of content, and more than one sponsored content section, this functionality is needed to protect revenue and user control.

Assignee: nobody → sdowne
Iteration: --- → 70.1 - Jul 8 - 21
Priority: -- → P1
Target Milestone: --- → Firefox 69
Blocks: 1567243
Status: NEW → RESOLVED
Closed: 4 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: Firefox 69 → Firefox 70

I have verified this issue with the latest Firefox Nightly (70.0a1 Build ID - 20190721215935) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the dismissed SPOC is replaced by a story.

Status: RESOLVED → VERIFIED

Does this need to be uplifted to Beta for Fx69?

Flags: needinfo?(sdowne)

Yup, that's still the plan.

Flags: needinfo?(sdowne)

Scott - since this has landed in nightly and has been verified, can you do the official Beta uplift request?

Flags: needinfo?(sdowne)

Comment on attachment 9080360 [details]
Bug 1562277 - Pocket New Tab - Revisit spoc dismissal flow

Beta/Release Uplift Approval Request

  • User impact if declined: User experience and potential revenue impact because of increased sponsored content opt outs.

  • Is this code covered by automated tests?: Yes

  • Has the fix been verified in Nightly?: Yes

  • Needs manual test from QE?: Yes

  • If yes, steps to reproduce: To test:

    Ensure your block list is empty.
    Load a new tab with spocs.
    Dismiss a spoc, it should be replaced with the next, non spoc card.
    Refresh, a new, spoc, but not the one you dismissed should be back.

  • List of other uplifts needed: None

  • Risk to taking this patch: Low

  • Why is the change risky/not risky? (and alternatives if risky): Small changeset, tested, verified, on nightly, has tests.

  • String changes made/needed: none

Flags: needinfo?(sdowne)
Attachment #9080360 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9080360 [details]
Bug 1562277 - Pocket New Tab - Revisit spoc dismissal flow

Improves the UX around sponsored content on the newtab page. Approved for 69.0b8.

Attachment #9080360 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified this issue with the latest Firefox Beta (69.0b8 Build ID - 20190725174626) installed, on Windows 10 x64, Arch Linux and Mac 10.14.6. Now, the dismissed SPOC is replaced by the next story, that will be also replaced by a SPOC after a refresh.

You need to log in before you can comment on or make changes to this bug.