Closed Bug 1562287 Opened 7 months ago Closed 7 months ago

Allow disabling 3-tier PGO builds on try.

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: tomprince, Assigned: tomprince)

References

Details

Attachments

(7 files)

Often times, PGO builds aren't required for testing things (in particular, testing release automation). However, at least when testing release automation, we do need to use the shippable build type.

Provide an option to mach try that will disable using the 3-tier PGO jobs.

Factor out the logic for calculating try_task_config from push_to_try,
so it can be called only for those selectors that need it.

Templates invoke the morph logic, which is somewhat confusing and inflexible.
Update the machinery to support setting other try_task_config values.

Often times, PGO builds aren't required for testing things (in particular,
testing release automation). However, at least when testing release automation,
we do need to use the shippable build type.

Add an option to mach try that will disable using the 3-tier PGO jobs.

Don't schedule the first 2 tiers of 3-tier PGO if they aren't going to be used.

Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/e4d3721c6fad
Don't advertise chemspill-prio in try syntax, since it isn't supported; r=ahal
https://hg.mozilla.org/integration/autoland/rev/08361960eaf4
Factor out generation of try_task_config; r=ahal
https://hg.mozilla.org/integration/autoland/rev/e5c77a0eaa15
Allow setting other try_task_config settings than `templates`; r=ahal
https://hg.mozilla.org/integration/autoland/rev/9e1f67f66b60
Add an option to `mach try` to disable 3-tier PGO; r=mshal,ahal
Regressions: 1563671
Flags: needinfo?(mozilla)
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/12c00b976820
[taskgraph] `try_task_config` parameter is now always a `dict`; r=aki
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/3183a958ad35
[taskgraph] Fix tests around `try_task_config; rs=me
You need to log in before you can comment on or make changes to this bug.