Closed Bug 1562390 Opened 1 year ago Closed 1 year ago

Intermittent gfx\tests\marionette\test_pref_rollout_workaround.py WrPrefRolloutWorkAroundTestCase.test_wr_rollout_workaround_on_non_qualifying_hw | AssertionError: Should start out as WR opt-in

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: kgupta [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=254075187&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/WqhjDZ8bT2S_FZZ1LVXUpg/runs/0/artifacts/public/logs/live_backing.log


Regression from bug 1558598, since WR is going to start out as explicitly disabled instead of "opt in" now.

Assignee: nobody → kats
Priority: P5 → P3
Regressed by: 1558598

I don't see any marionette API that would let me remove the envvar, so maybe we can just ignore the envvar in the code if the marionette test is running. https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&tier=1%2C2%2C3&revision=5a5809deb21e020796621dfe21493a325750d900

That seems to work. However I'm not sure if there's much value in keeping this test going forward, since I don't know how much longer we'll be using Normandy to do the WR rollout. Will talk to people about this after the weekend, but for now I can land the patch as a temporary fix.

Keywords: leave-open
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a120e7b0d305
Ignore MOZ_WEBRENDER=0 for the WR rollout marionette test. r=me

Based on IRC discussion we might still be using the rollout code in 69, so it's probably better to leave the code and test as it is right now, and close this bug.

Status: NEW → RESOLVED
Type: -- → defect
Closed: 1 year ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.