Closed Bug 1562427 Opened 4 months ago Closed 4 months ago

Can we revert bug 1540984 now?

Categories

(WebExtensions :: Themes, task)

task
Not set

Tracking

(firefox69 verified)

VERIFIED FIXED
mozilla69
Tracking Status
firefox69 --- verified

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

AFAICT, even though the underlying issue is still not fixed, bug 1554405 should have fixed it too, right?

Can we stop using -moz-element now?

Flags: needinfo?(kmaglione+bmo)

If you want to test some Firefox try-build, just needinfo me, I will glad to help.

QA Contact: Virtual

If reverting it doesn't trigger flickering when opening or focusing windows with themes with large background images, sure.

Flags: needinfo?(kmaglione+bmo)

Ok, I'll prepare a build so Virtual can test it (probably Monday material though). Thanks both!

Flags: needinfo?(emilio)

Virtual, mind giving this build a spin?

Thank you!

Flags: needinfo?(emilio) → needinfo?(Virtual)
Attached video screencast.mp4

I done STR from bug #1540984 comment #21 and I can't reproduce that issue with this build ( https://treeherder.mozilla.org/#/jobs?repo=try&revision=a057db5eb2bd9682ae7c94f86cb0fb36050d9203 - I tested "Windows 2012 x64 shippable opt" one ). So green light from me. Thank you very much! \o/

Flags: needinfo?(Virtual)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b3cf4a82ce4
Back out bug 1540984, since bug 1554405 fixes it in a way that doesn't need -moz-element(). r=kmag

Thanks for testing Virtual!

Assignee: nobody → emilio
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

(In reply to Emilio Cobos Álvarez (:emilio) from comment #8)

Thanks for testing Virtual!

My pleasure!

I also confirming that bug is fixed, starting in Mozilla Firefox Nightly 69.0a1 (2019-07-04), so I'm marking this bug as VERIFIED.
Thank you very much one more time! \o/

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.