Closed Bug 1562432 Opened 2 years ago Closed 2 years ago

Firefox fails opening the site www.cronista.com

Categories

(Web Compatibility :: Desktop, defect, P3)

defect

Tracking

(firefox67 affected)

RESOLVED WORKSFORME
Tracking Status
firefox67 --- affected

People

(Reporter: roquejose2000, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: webcompat:needs-diagnosis, Whiteboard: [qf-])

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Opening the site www.cronista.com (Argentinian newspeper) in Firefox on Ubuntu and on Android.

Actual results:

It fails, text and image move all the time until you click on stop button.

Expected results:

The site would be static, as on Chromium.

It fails, text and image move all the time until you click on stop button.

Not here...

Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables add-ons, extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems.) See https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
And does this also happen with a new and empty profile? See https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile

Flags: needinfo?(roquejose2000)

Hi Roque,hi Andre,

I was able to reproduce it on FF 67.0.4 (32-bit) on Ubuntu 16.04 LTS 32 bits. I attach a video of the bug. Also, a minute after the video, the page crashed. I attach a picture of the crash and here's the crash log (if I did it right):

about:cache-entry?storage=memory&context=&eid=-unique:https://www.cronista.com&uri=https://api.cxense.com/public/widget/data?json=%7B%22context%22%3A%7B%22referrer%22%3A%22https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html%22%2C%22autoRefresh%22%3Atrue%2C%22url%22%3A%22https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html%22%7D%2C%22widgetId%22%3A%22295e2a5ffd58abf9cdc147f68fe8a9792adad5b6%22%2C%22user%22%3A%7B%22ids%22%3A%7B%22usi%22%3A%22jxn9pgomuhzaw7l6%22%7D%7D%2C%22prnd%22%3A%22jxn9rtl7ee058lgk%22%7D&media=javascript&widgetId=295e2a5ffd58abf9cdc147f68fe8a9792adad5b6&resizeToContentSize=true&ctx=https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html&usi=jxn9pgomuhzaw7l6&prnd=jxn9rtl7ee058lgk&tzo=180&useSecureUrls=true&rnd=135858905&callback=cXJsonpCBjxn9rtv9kd8ky9e7

I've chosen a component. If you consider that there's another component that's more proper for this case you may change it.

Best regards, Flor.

Status: UNCONFIRMED → NEW
Component: Untriaged → Networking
Ever confirmed: true
Flags: needinfo?(roquejose2000)
Product: Firefox → Core

(In reply to Florencia Marina Di Ciocco from comment #2)

Hi Roque,hi Andre,

I was able to reproduce it on FF 67.0.4 (32-bit) on Ubuntu 16.04 LTS 32 bits. I attach a video of the bug. Also, a minute after the video, the page crashed. I attach a picture of the crash and here's the crash log (if I did it right):

about:cache-entry?storage=memory&context=&eid=-unique:https://www.cronista.com&uri=https://api.cxense.com/public/widget/data?json=%7B%22context%22%3A%7B%22referrer%22%3A%22https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html%22%2C%22autoRefresh%22%3Atrue%2C%22url%22%3A%22https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html%22%7D%2C%22widgetId%22%3A%22295e2a5ffd58abf9cdc147f68fe8a9792adad5b6%22%2C%22user%22%3A%7B%22ids%22%3A%7B%22usi%22%3A%22jxn9pgomuhzaw7l6%22%7D%7D%2C%22prnd%22%3A%22jxn9rtl7ee058lgk%22%7D&media=javascript&widgetId=295e2a5ffd58abf9cdc147f68fe8a9792adad5b6&resizeToContentSize=true&ctx=https%3A%2F%2Fwww.cronista.com%2Feconomiapolitica%2FEmpieza-a-conocerse-parte-la-letra-chica-del-acuerdo-UE-Mercosur-y-expone-algunas-sorpresas-20190702-0062.html&usi=jxn9pgomuhzaw7l6&prnd=jxn9rtl7ee058lgk&tzo=180&useSecureUrls=true&rnd=135858905&callback=cXJsonpCBjxn9rtv9kd8ky9e7

I've chosen a component. If you consider that there's another component that's more proper for this case you may change it.

Best regards, Flor.

This is not a crash report. Please see https://support.mozilla.org/en-US/kb/mozillacrashreporter.
Could you reproduce this again? Thanks.

Flags: needinfo?(fdiciocco)

Hi Flor, Kershaw and Andre, I can also confirm this bug on Android current version, and at least from a year ago.
Greetings.

Hi Kershaw,

Here's the crash: https://crash-stats.mozilla.org/report/index/ebbc8683-e2b7-4f5d-9351-46d520190715. Sorry for the delay, I was sick.

Best regards, Flor.

Flags: needinfo?(fdiciocco)

(In reply to Florencia Marina Di Ciocco from comment #7)

Hi Kershaw,

Here's the crash: https://crash-stats.mozilla.org/report/index/ebbc8683-e2b7-4f5d-9351-46d520190715. Sorry for the delay, I was sick.

Best regards, Flor.

Looks like this crash report comes from an unofficial or a custom build, there are no symbols, so we can't read anything out of it.

Flags: needinfo?(fdiciocco)

So, can I help you by doing something in particular? Because I followed the steps you gave me to get that bug.

Best regards, Flor.

Flags: needinfo?(fdiciocco) → needinfo?(honzab.moz)

OK, looks like you are using an unofficial build. Can you try installing Nightly for your platform from Mozilla Firefox Web Browser — Download Firefox Nightly in your language — Mozilla and retry?

Flags: needinfo?(honzab.moz) → needinfo?(roquejose2000)

Hi Honza,

So with this official version of nightly I still get the glitch but I don't get the crash. I left the page untouched for like half an hour and every 3 or 5 minutes it would twitch like in the video I had attached before.

Best regards, Flor.

I honestly don't understand the symptoms at all and it doesn't sound like a net issue to me. Moving to general for re-triage.

Component: Networking → General

I can reproduce what the bug reporter describes as 'text and image move all the time', on Ubuntu, Nightly 20190724095428.

https://perfht.ml/2YgTXcD, by looking at the profile, it looks like we kept reprocess some scripts, not sure if this is a problem.

I can also reproduce on my Mac, lots of layout jank during page load. Page load also takes much longer on Firefox than it does on Chrome. NI dholbert for insight into the layout jank.

Flags: needinfo?(dholbert)
Whiteboard: [qf]

The layout jank seems to mostly come from several scripted clientWidth accesses, each of which cause a synchronous layout flush (the longest of which is 25ms in duration, in sefeng's profile).

It's possible that the layout flushes are longer than they need to be; they do involve some flexbox layout and there are known cases where flexbox relayout is more aggressive than necessary. --> Marking as blocking bug 1304473 for now (the general flexbox perf issues bug) on the assumption that this might be the case.

Flags: needinfo?(dholbert)

The twitching doesn't seem like a performance problem to me. When comparing it to Chrome, Chrome loads the page almost instantly without any layout jank while Firefox seems to be stuck in some kind of infinite loop loading the top ad over and over again. NI'ing Mike to see if it's maybe a web compat problem?

Component: General → Desktop
Flags: needinfo?(miket)
Product: Core → Web Compatibility
Whiteboard: [qf] → [qf-]
Version: 67 Branch → unspecified
Attached video loop.mov

Yeah, we're stuck in some kind of load loop -- while writing this comment it finally settled down and loaded an ad, and at times it seems like it's loading itself in an iframe.

Flags: needinfo?(miket)
Priority: -- → P3

Ah, I think I had to disable tracking protection to get the ad to stick. Might be related.

I'm not seeing any such looping on the site now, in strict or basic tracking, or even with it disabled. Is it still reproducing for you, Mike? I wonder if it's ad-specific?

Flags: needinfo?(miket)

everything seems to be working for me.
temporary issue?

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(miket)
Flags: needinfo?(roquejose2000)
You need to log in before you can comment on or make changes to this bug.