Closed Bug 156244 Opened 18 years ago Closed 18 years ago

If DOCTYPE specified, page is rendered incorrectly (element's extra spaces on bottom)

Categories

(SeaMonkey :: General, defect)

PowerPC
All
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 22274

People

(Reporter: mora, Assigned: Matti)

References

()

Details

All pages in www.roam.it website and in www.romanaegentes.it correctly validates
as HTML 4.01 Frameset and Strict by W3C; so are the CSS.

If in the source the <!DOCTYPE...> tag is present, regardless his contents, the
pages acquires extra vertical spaces, table rows grows in height with extra
pixels on bottom and linked images reports extra bottom border.

Changing the DOCTYPE declaration doesn't solves, comment (or remove) them solves.

This happens ever and in every Mozilla build later than 0.9.4 and in every
operating system (Mac OS (X), Win* and Linux (intel) RedHat and Slackware
personally tested). Other platforms also reported.
See also bug #153032 for the implementation of an "almost standards" rendering.

In any case, in presence of a DOCTYPE triggering the standard mode, Mozilla will
display the way W3C standards are requesting.

*** This bug has been marked as a duplicate of 22774 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Typ error
Dupe of bug 22274
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 22274 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.