mozilla/mail hangs, forces kill -9 mozilla when i try to forward mail

CLOSED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
CLOSED WORKSFORME
16 years ago
13 years ago

People

(Reporter: frontloader, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610
BuildID:    1.1 alpha

mail client hangs and is completely unresponsive after an attempt to forward
mail. the mail mail seems to go out, and the GUI displays the appropriate
`client working' type dialog for the out going forwarded mail.. but as soon as
that dialog closes the client hangs. it affects all the mozilla clients in that
they all become unresponsive and forces a kill -9 [or equivelent] to all running
mozilla processes.

Reproducible: Always
Steps to Reproduce:
1.start mozilla
2.use ctrl-2 to start mail client
3.login to mail server
4.click on sent mail folder in primary mail
5.double-click any single mail in sent box to open
6.click 'forward' menu tile on newly opened mail
7.use ctrl-'return' to send mail
8.`working' dialog appears as mail is sent.
9.all mozilla GUIs are now hung.

Actual Results:  i must close all unresponsive mozilla client GUIs.. sometimes
[once or twice] i have to restart X. it appears that mail is actually sent
properly.. so other than having to recover by closing/restarting mozilla, it
seems ok.

Expected Results:  not to hang after mail send. allow user to proceed [i.e.
close forwarded mail if i want to, browse `inbox'.. etc]

i am using enlightenment 16.5/RedHat 7.3, may be related, however.. this issue
did not appear until 1.1. alpha.. i use enlightenment/mozilla/mozilla-mail daily
in my work as an engineer for the past 14 months.
worksforme linux trunk cvs 2002-07-08. Reporter, as 1.1a is a month old now,
could you test this on a nightly build
<http://ftp.mozilla.org/pub/mozilla/nightly/latest/>? Does this happen when
forwarding any message, or a specific (type of) message?
Severity: normal → critical
Keywords: hang
(Reporter)

Comment 2

16 years ago
ok, just downloaded and tried the latest nightly-build [Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:1.1a+) Gecko/20020708].. same behavior.. client hangs.
however, it looks like i may have missed a step before:

..
7.use ctrl-'return' to send mail
8.`working' dialog appears as mail is sent.
>> 8a. when client reverts to orginating forwarded message, click File->Close,
or window-manager `close window' widget..
9.all mozilla GUIs are now hung.
..

i can still drag the window interface around, but it stops refreshing and is
unresponsive.

perhaps you can help me find some error logs i can tail?
still wfm (sawfish 1.0.1, debian testing, fwiw) :\

Updated

16 years ago
QA Contact: olgam → meehansqa

Comment 4

15 years ago
works for me Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030112
(Reporter)

Comment 5

15 years ago
i am now using:
Mozilla 1.3a Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212 

i follow the same steps in the below bug i reported and the client works perfectly. 
fwiw i never was able to figure out what was wrong before, i just stopped
ever forwarding mail.

mozilla is a great client! you guys rock!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 6

15 years ago
Marking as CLOSED WFM. Reporter agrees
Status: RESOLVED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.