Closed Bug 1562537 Opened 8 months ago Closed 5 months ago

Popup Menu Items in SeaMonkey download progress dialog do not work

Categories

(SeaMonkey :: Download & File Handling, defect)

SeaMonkey 2.53 Branch
Unspecified
Windows
defect
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: LD-531, Assigned: frg)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.53

Actual results:

download progress dialog click "from [url]" show a menu, click "copy download link" or "go to download page" --> do nothing :(
but download manager on downloaded/ing item right-click "copy download link" and "go to download page" still work :)

下载进度对话框、点击“从 【网址】”弹出的菜单“复制下载链接”和“转至下载页面”命令不起作用。
但在下载管理器窗口、在下载中/已下载项目的右键菜单中的相同命令却正常。

Expected results:

i believe this only a small problem.

我相信这只是个小问题。

REPRODUCIBLE with installation of unofficial (by wg9s) en-US SeaMonkey 2.53 (NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20190412032805 (Default Classic Theme, German Language Pack active) on German WIN7 64bit
0. ˋMenu 'Edit → Settings → Browser → Downloads → Click 'Open Progress Dialog when start donload' → [OK]ˊ

  1. Goto https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/2019-06-30_23.26.40/
  2. ˋClick on biggest file for download → Start Download with "save file"ˊ
  3. Go to progress dialog
    » Second line (the one below file name) shows a pull down menu with items "Go to download page"
    and "Copy download link"
    Expected: both items work
    Actual: none of them works 😥

Additional Info:
a) 2.53 for now!
b) Due to https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=1562537DUPs&sharer_id=41036 there seems to be no obvious DUPs.
Bug 156112 and Bug 100179 are concerning a different problem.
c) In Download Manager context Menu items with same functions do work

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: 2.53/2.57 download progress dialog some menu commands not work(2.53/2.57 下载进度对话框的一些菜单命令不起作用) → 2.53/2.57 Menu Items in ˋdownload progress dialogˊ do not work
Version: SeaMonkey 2.57 Branch → SeaMonkey 2.53 Branch

d) WIN for now
e) Was still ok with Installation of official DE SeaMonkey 2.49.1 (NT 6.1; WOW64; rv:52.0) Gecko/20100101
Firefox/52.0 Build 20171016030418 (Default Classic Theme) on German WIN7 64bit
so: regression

Keywords: regression
OS: Unspecified → Windows

Bug 888915 switched SeaMonkey to jsdownloads. I needed to fix a similar problem for the download manager some time ago. Just forgot the progress dialog it seems.

Depends on: 888915
Flags: needinfo?(frgrahl)
Summary: 2.53/2.57 Menu Items in ˋdownload progress dialogˊ do not work → Some Menu Items in SeaMonkey download progress dialog do not work
Flags: needinfo?(frgrahl)
Summary: Some Menu Items in SeaMonkey download progress dialog do not work → Popup Menu Items in SeaMonkey download progress dialog do not work
Flags: needinfo?(frgrahl)

Sorry it took so long. Will be in Bills next build.

The dialog has some other problems if opened from the download manager. Will show as progressing even if the downloads is complete.

[Approval Request Comment]
Regression caused by (bug #): 888915
User impact if declined: links not working
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): no risk broken already
String changes made by this patch: --

Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Flags: needinfo?(frgrahl)
Attachment #9098928 - Flags: review?(iann_bugzilla)
Attachment #9098928 - Flags: approval-comm-release?
Attachment #9098928 - Flags: approval-comm-esr60?
Comment on attachment 9098928 [details] [diff] [review]
1562537-fixlinks.patch

[Triage Comment]
lgtm r/a=me
Attachment #9098928 - Flags: review?(iann_bugzilla)
Attachment #9098928 - Flags: review+
Attachment #9098928 - Flags: approval-comm-release?
Attachment #9098928 - Flags: approval-comm-release+
Attachment #9098928 - Flags: approval-comm-esr60?
Attachment #9098928 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/7a012f5b023e
Fix links in download progress dialog. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.