Closed Bug 1562551 Opened 1 year ago Closed 1 year ago

Poison less memory between minor GCs

Categories

(Core :: JavaScript: GC, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1562550

People

(Reporter: pbone, Assigned: pbone)

References

Details

(Keywords: perf)

We're poisoning more memory than we need to when we re-initalise a chunk after a minor GC. We can avoid poisoning the memory that was not touched by the previous cycle.

For example, if we have 512KB nursery capacity and we allocate 128KB and then collect the nursery due to an API call or full remembered set. We initially poison 128KB after evicting it, but then we poison the entire 512KB when we re-initalise the same chunk. We can avoid this because the 512-128KB section of the nursery would have been initalised by either a previous collection or nursery initialisation.

This will improve performance for the nightly channel and therefore improve the telemetry we see returned there. It won't affect release, but the telemetry we see on nightly will then be closer to what release achieves.

Assignee: nobody → pbone
Status: NEW → ASSIGNED
Priority: -- → P2

I will change Bug 1562550 to cover a patch for this bug also.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1562550
You need to log in before you can comment on or make changes to this bug.