Closed Bug 1562568 Opened 3 years ago Closed 3 years ago

11.93 - 15.1% perf_reftest_singletons (linux64-shippable, linux64-shippable-qr, windows10-64-shippable, windows10-64-shippable-qr, windows7-32-shippable) regression on push 94b01ff1b1618e9d677a85783be045c9f464f30d (Thu June 27 2019)

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Bebe, Unassigned)

References

(Regression)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=94b01ff1b1618e9d677a85783be045c9f464f30d

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

15% perf_reftest_singletons windows7-32-shippable opt e10s stylo 43.91 -> 50.54
15% perf_reftest_singletons windows10-64-shippable opt e10s stylo 43.76 -> 50.32
15% perf_reftest_singletons windows10-64-shippable-qr opt e10s stylo 43.87 -> 50.36
14% perf_reftest_singletons linux64-shippable opt e10s stylo 41.84 -> 47.85
14% perf_reftest_singletons linux64-shippable-qr opt e10s stylo 43.68 -> 49.94
12% perf_reftest_singletons windows7-32-shippable opt e10s stylo 45.04 -> 50.41

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=21686

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Blocks: 1549347
Component: General → Layout
Product: Testing → Core
Version: Version 3 → unspecified
Flags: needinfo?(cam)

These are expected, since I added a new subtest to perf_reftest_singletons, which changes the reported value for the test suite as a whole.

Flags: needinfo?(cam)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.