Closed Bug 1562750 Opened 4 months ago Closed 3 months ago

GUI for adding language packs is broken

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(thunderbird68+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird68 + fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: nONoNonO, Assigned: nONoNonO)

References

(Blocks 1 open bug)

Details

(Keywords: intl)

Attachments

(1 file)

When you toggle the pref intl.multilingual.enabled to true (and probably also the pref intl.multilingual.downloadEnabled), you get a Languages box in ToolS > Options > Advanced > General. When you click on the language and select "Search for more languages…", a popup window appears, where you should be able to add more languages.
This window is broken however, and displays an error message:
{ -brand-short-name } can't update your languages right now. Check that you are connected to the internet or try again.
There should also be an icon displayed in front of the message, but that icon <chrome://browser/skin/identity-icon.svg> isn't included inThundernbird.

In order for the window to work, the pref extensions.getAddons.langpacks.url should be added to Thunderbird, pointing to https://services.addons.thunderbird.net/api/v3/addons/language-tools/?app=thunderbird&type=language&appversion=68

And then of course also the build process should work again so that the language packs on addons.thunderbird.net get updated again.

See here where the pref is used: https://searchfox.org/comm-central/source/mozilla/toolkit/mozapps/extensions/internal/AddonRepository.jsm#785

Richard, this is meant to be disabled. How come it's suddenly enabled again?

It's not suddenly enabled. Onno wrote, he enabled intl.multilingual.downloadEnabled. The download isn't enabled in TB because ATN has no actual language packs on its site and the upload of this packages isn't automatically done. So this is invalid or we need to look that Rob looks for the upload and Andrei implements the website needs. There should be a bug for this but I'm at work and can't search for it.

And about the icon: This comes from https://searchfox.org/comm-central/source/mozilla/toolkit/themes/shared/in-content/common.inc.css#920. Again they point from a toolkit file to a browser resource.

(In reply to Richard Marti (:Paenglab) from comment #2)

And about the icon: This comes from https://searchfox.org/comm-central/source/mozilla/toolkit/themes/shared/in-content/common.inc.css#920. Again they point from a toolkit file to a browser resource.

Should I clone this bug for the icon issue to toolkit?

You can, and CC me please.

Regardless of the issue with the icon and the issue with the language packs themselves not being available on ATB, I think the pref extensions.getAddons.langpacks.url should be added to Thunderbird...

Blocks: 1562940
Keywords: intl

Add missing pref to Thunderbird profile, so language pack install can work,
once they become available on addons.thunderbird.net.

Comment on attachment 9077717 [details]
Bug 1562750 - Add missing pref to thunderbird profile

Onno, no need to use Phabricator for C-C. Andrei seems to have no account. And I think, it's better he checks the URL because he's the server guy.

Andrei, the pref would be this:

pref("extensions.getAddons.langpacks.url", "https://services.addons.thunderbird.net/api/v3/addons/language-tools/?app=thunderbird&type=language&appversion=%VERSION%");

Would this be the correct URL?

Attachment #9077717 - Flags: review?(sancus)

Comment on attachment 9077717 [details]
Bug 1562750 - Add missing pref to thunderbird profile

Yeah, that URL looks correct to me, and also seems to work as expected: https://services.addons.thunderbird.net/api/v3/addons/language-tools/?app=thunderbird&type=language&appversion=60.8.0

Attachment #9077717 - Flags: review?(sancus) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/305c070b0794
Add pref for language pack install. r=sancus DONTBUILD

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Please request uplifts as you deem fit.

Target Milestone: --- → Thunderbird 70.0

Comment on attachment 9077717 [details]
Bug 1562750 - Add missing pref to thunderbird profile

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

Attachment #9077717 - Flags: approval-comm-esr68?
Attachment #9077717 - Flags: approval-comm-beta?

Comment on attachment 9077717 [details]
Bug 1562750 - Add missing pref to thunderbird profile

OK, stuff will find its way to ESR via the beta. But it all doesn't help if ATN isn't up to it yet.

Attachment #9077717 - Flags: approval-comm-esr68?
Attachment #9077717 - Flags: approval-comm-beta?
Attachment #9077717 - Flags: approval-comm-beta+
Assignee: nobody → o.e.ekker
You need to log in before you can comment on or make changes to this bug.