Closed Bug 1562792 Opened 7 months ago Closed 6 months ago

Fix and re-enable browser_html_abuse_report.js on Windows

Categories

(Toolkit :: Add-ons Manager, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: kmag, Assigned: rpl)

Details

Attachments

(1 file, 1 obsolete file)

browser_html_abuse_report.js does some dodgy things combining undoable uninstalls with ExtensionTestUtils-created extensions. It assumes that it can call cancelUninstall() and then immediately call unload() on the relevant object.

Even assuming that the extension wrapper correctly handles uninstalling a different instance of the extension after a shutdown and restart triggered by the uninstall and cancel, the cancelUninstall() method does not return a promise that waits until the extension has fully started before resolving, which means that the uninstall attempt sometimes leads to file locking errors on Windows when the extension hasn't finished restarting.

Status: NEW → ASSIGNED
Priority: -- → P1
Attachment #9075466 - Attachment is obsolete: true
Attachment #9076531 - Attachment description: Bug 1562792 - Prevent extension file locking issues due to browser_html_abuse_report.js test cases. r?kmag! → Bug 1562792 - Prevent extension file locking issues due to browser_html_abuse_report.js test cases. r=robwu
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/f594267f820c
Prevent extension file locking issues due to browser_html_abuse_report.js test cases. r=robwu
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Whiteboard: [checkin-needed-beta]

Hello,

Will this fix require manual validation? If yes, please provide some steps to reproduce in order to correctly test it and also, please set the "qe-verify+" flag. Otherwise, could the "qe-verify-" flag be added? Thanks!

Flags: needinfo?(lgreco)

Setting qe-verify-, test-only patch.

Flags: needinfo?(lgreco) → qe-verify-
You need to log in before you can comment on or make changes to this bug.