Closed Bug 1562868 Opened 3 years ago Closed 2 years ago

Crash in [@ mozilla::ipc::ProcessLink::SendMessage | IPC_Message_Name=PCookieService::Msg_SetCookieString]

Categories

(Core :: Networking: Cookies, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- fixed

People

(Reporter: gsvelto, Assigned: baku)

References

Details

(Keywords: crash, Whiteboard: [necko-triaged])

Crash Data

Attachments

(1 file, 2 obsolete files)

This bug is for crash report bp-aa6306f9-7763-473d-b254-b4ec90190630.

Top 10 frames of crashing thread:

0 xul.dll mozilla::ipc::ProcessLink::SendMessage ipc/glue/MessageLink.cpp:152
1 xul.dll mozilla::ipc::MessageChannel::Send ipc/glue/MessageChannel.cpp:995
2 xul.dll mozilla::net::PCookieServiceChild::SendSetCookieString ipc/ipdl/PCookieServiceChild.cpp:104
3 xul.dll nsresult mozilla::net::CookieServiceChild::SetCookieStringInternal netwerk/cookie/CookieServiceChild.cpp:553
4 xul.dll nsresult mozilla::net::CookieServiceChild::SetCookieString netwerk/cookie/CookieServiceChild.cpp:664
5 xul.dll mozilla::dom::Document::SetCookie dom/base/Document.cpp:5539
6 xul.dll static bool mozilla::dom::Document_Binding::set_cookie dom/bindings/DocumentBinding.cpp:2420
7 xul.dll mozilla::dom::binding_detail::GenericSetter<mozilla::dom::binding_detail::NormalThisPolicy> dom/bindings/BindingUtils.cpp:3124
8 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:540
9 xul.dll js::CallSetter js/src/vm/Interpreter.cpp:749

The raw crash reason is:

MOZ_CRASH(IPC message size is too large) - This is super sensitive data! Be careful how you use it!

This doesn't seem like a new bug, it just happens I spotted it while triaging nightly.

Component: IPC → Networking: Cookies

Honza, can you take a look?

Not sure if we can send cookie string in chunks, like this.
Set it to P3 for now, since the crash rate is low.

Priority: -- → P3
Whiteboard: [necko-triaged]
Assignee: nobody → amarchesini
Status: NEW → ASSIGNED
Duplicate of this bug: 1187736
Attachment #9134183 - Attachment is obsolete: true
Attachment #9134182 - Attachment is obsolete: true
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8bfef0a3dd3
Limit the amount of data shared between processes when document.cookie is set, r=smaug
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Regressions: 1650211
Regressions: 1656980
You need to log in before you can comment on or make changes to this bug.