Closed Bug 1562923 Opened 4 months ago Closed 4 months ago

Check if raptor web-extension was installed before attempting to uninstall

Categories

(Testing :: Raptor, task, P1)

Version 3
task

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: sparky, Assigned: sparky)

Details

Attachments

(1 file)

Currently, when a test fails before the test starts and installs the raptor webextension to raptor_webext we fail when we try to uninstall the extension, see this failure (caused by a key error within power.py): https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=3a923c2df79d5a7a911ab58c3a2f9f3ffb33f0cc&selectedJob=253611350

We should check if the raptor web extension was installed before attempting to uninstall it.

This patch makes Raptor check if the web extension was installed before attempting to uninstall it.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/d6a437cfeb78
Check if raptor web extension is installed before uninstalling. r=perftest-reviewers,Bebe,alexandru.irimovici
Status: NEW → ASSIGNED
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.