Closed Bug 1563032 Opened 5 months ago Closed 5 months ago

Crash in [@ mozilla::dom::BodyStream::ReleaseObjects]

Categories

(Core :: DOM: Core & HTML, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: marcia, Assigned: baku)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-229de28e-8abe-472c-9cad-5e59c0190702.

Seen while looking at nightly crashes - one crash so far on macOS. It seems this is after the work in Bug 1557781 landed. ni on :baku

Top 10 frames of crashing thread:

0 XUL mozilla::dom::BodyStream::ReleaseObjects dom/base/BodyStream.cpp:489
1 XUL non-virtual thunk to mozilla::dom::BodyStream::finalize dom/base/BodyStream.cpp
2 XUL ReadableStreamControllerClearAlgorithms js/src/builtin/Stream.cpp:2969
3 XUL ReadableStreamControllerError js/src/builtin/Stream.cpp:3139
4 XUL JS::ReadableStreamError js/src/builtin/Stream.cpp:4920
5 XUL mozilla::dom:: dom/fetch/Fetch.cpp:78
6 XUL mozilla::dom::FetchBody<mozilla::dom::Response>::GetBody dom/fetch/Fetch.cpp:1346
7 XUL mozilla::dom::Response_Binding::get_body dom/bindings/ResponseBinding.cpp:1261
8 XUL bool mozilla::dom::binding_detail::GenericGetter<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3067
9 XUL js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:540

Flags: needinfo?(amarchesini)
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Duplicate of this bug: 1563215
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45d9572f4a37
BodyStream must check the return value of BodyStreamHolder::GetReadableStreamBody(), r=smaug
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Crash Signature: [@ mozilla::dom::BodyStream::ReleaseObjects] → [@ mozilla::dom::BodyStream::ReleaseObjects] [@ JS_SetPrivate]
Duplicate of this bug: 1562784
Crash Signature: [@ mozilla::dom::BodyStream::ReleaseObjects] [@ JS_SetPrivate] → [@ mozilla::dom::BodyStream::ReleaseObjects] [@ JS_SetPrivate] [@ mozilla::dom::FetchBody<mozilla::dom::EmptyBody>::ReadableStreamBody() + 0x54]
Crash Signature: [@ mozilla::dom::BodyStream::ReleaseObjects] [@ JS_SetPrivate] [@ mozilla::dom::FetchBody<mozilla::dom::EmptyBody>::ReadableStreamBody() + 0x54] → [@ mozilla::dom::BodyStream::ReleaseObjects] [@ JS_SetPrivate] [@ mozilla::dom::FetchBody<mozilla::dom::EmptyBody>::ReadableStreamBody() + 0x54]
You need to log in before you can comment on or make changes to this bug.