Closed Bug 1563040 Opened 4 months ago Closed 3 months ago

When opening a new window call "focus()" without using "setTimeout"

Categories

(Testing :: Marionette, task, P1)

69 Branch
task

Tracking

(firefox68 wontfix, firefox69 wontfix, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

Attachments

(1 file)

Due to bug 1509234 I had to make use of setTimeout() when letting Marionette open a new window (bug 1504756). Once bug 1509234 has been fixed, we can get rid of this workaround.

The test failure (crash) only happened for MacOS debug builds of Firefox on 10.10. Given that we run Marionette tests for mozilla-central on MacOS 10.14 in CI now, and bug 1509234 is wontfix, we should get the workaround removed.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P3 → P1
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0eaeadceac47
[marionette] Call window.focus() directly for the newly opened window. r=webdriver-reviewers,ato
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1565391

Sheriffs please backout this patch from mozilla-central and mozilla-beta. Thanks!

Flags: needinfo?(sheriffs)
Flags: needinfo?(sheriffs)
Whiteboard: [checkin-needed-beta]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [checkin-needed-beta]
Target Milestone: mozilla69 → ---
Whiteboard: [checkin-needed-beta]
Backout by dvarga@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1661d348710
Backed out changeset 0eaeadceac47 requested by whimboo

Resetting bug status given that it is blocked on a core crash.

Assignee: hskupin → nobody
Status: REOPENED → NEW
Priority: P1 → P3
Whiteboard: [checkin-needed-beta]
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P3 → P1
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec74edc9b30a
[marionette] Call window.focus() directly for the newly opened window. r=webdriver-reviewers,ato
Status: ASSIGNED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Is this something we need to backport to Beta or can this ride with 70?

Flags: needinfo?(hskupin)

We cannot uplift to beta because bug 1509234 won't be uplifted.

Flags: needinfo?(hskupin)
You need to log in before you can comment on or make changes to this bug.