Closed Bug 1563121 Opened 1 year ago Closed 5 months ago

Use HTML input instead of XUL textbox in messengercompose.xul

Categories

(Thunderbird :: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: aleca, Assigned: aleca)

References

Details

Attachments

(1 file, 1 obsolete file)

Assignee: nobody → alessandro
Mentor: alessandro
Status: NEW → ASSIGNED
Attached patch 1563121-textbox-html-input.patch (obsolete) — Splinter Review
Attachment #9092269 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9092269 [details] [diff] [review]
1563121-textbox-html-input.patch

Review of attachment 9092269 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/compose/content/messengercompose.xul
@@ +2074,5 @@
>                <label id="subjectLabel" value="&subject.label;" accesskey="&subject.accesskey;" control="msgSubject"/>
>              </hbox>
> +            <hbox flex="1" align="center" class="input-container">
> +              <html:input id="msgSubject"
> +                          class="toolbar input-inline"

toolbar? would think that should not be there (though it was)

::: mail/themes/osx/mail/compose/messengercompose.css
@@ +190,5 @@
>    margin-bottom: 4px;
>    margin-inline-end: 6px;
>  }
>  
> +html|input#msgSubject {

I think it's preferred not to specify type and such for with an id (slightly slower, and unncessary)
Attachment #9092269 - Flags: review?(mkmelin+mozilla)

(In reply to Magnus Melin [:mkmelin] from comment #2)

html|input#msgSubject {

I think it's preferred not to specify type and such for with an id (slightly
slower, and unncessary)

Without specifying the type the style is not applied.
Do you know why it's happening?

Flags: needinfo?(mkmelin+mozilla)

I've been looking and asking around and it seems like it's not possible to style and HTML element inside a XUL file without specifying the element type itself.
I guess we could leave it like that for now, and then remove it once we transition to XHTML files.

Do you have a better solution?

Not sure if it's a bug or not... (though reading MDN, probably).
Looks like you can remove the default xul namespace in messengercompose.css and then it will work with just the id as selector.

Flags: needinfo?(mkmelin+mozilla)

That worked.
Are we sure removing the XUL namespace won't affect the styling of other elements?

Attachment #9092269 - Attachment is obsolete: true
Attachment #9092732 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9092732 [details] [diff] [review]
1563121-textbox-html-input.patch

Review of attachment 9092732 [details] [diff] [review]:
-----------------------------------------------------------------

It shouldn't. r=mkmelin
Attachment #9092732 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7c55e731be18
Use HTML input instead of XUL textbox in messengercomposer.xul. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
Regressions: 1581482
You need to log in before you can comment on or make changes to this bug.