Closed Bug 1563554 Opened 3 years ago Closed 3 years ago

Netflix CDM playback issues with ESR: 60.8.0 and 68.0

Categories

(Core :: Audio/Video: GMP, defect)

Desktop
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected

People

(Reporter: cfogel, Unassigned)

Details

(Keywords: regression)

Affected versions

  • 60.8.0 ESR, 68.0 ESR

Affected platforms

  • macOS 10.14 Windows(10) and Ubuntu(18.04)

Steps to reproduce

  1. Install Firefox 60.8.0 ESR
  2. Launch Firefox with a fresh profile and access Netflix with a valid account;
  3. Access the following link

Expected result

  • video plays without issues;
  • Widevine version is 4.10.1440.18

Actual result

  • video not played, error F7361-1254 displayed;
  • checking in about:addons, the mentioned extension is not installed.

Additional notes

  • 67.0.4, 69.0a1(20190704094530) is not affected
  • on Windows(10) and Ubuntu(18.04) it's more or less intermittent.

Removing blocker id, not the case.

Group: mozilla-employee-confidential

Clarifying: this impacts all the desktop platforms, but on Win + Linux it's intermittent? On Mac it is consistently failing?

Flags: needinfo?(cristian.fogel)

Yes, pretty much. macOS appears to be @90% of the time.

Flags: needinfo?(cristian.fogel)

I've just tested and I see a consistent fail on Windows. I would expect this to fail on all platforms for ESR -- when it doesn't error, does playback work?

That specific link leads to a CBCS encrypted Netflix stream (though oddly it appears to only be when given the videoParams param with those args -- otherwise it works in ESR which implies it's no CBCS). We've been landing cbcs support patches since 66 but we haven't uplifted any to ESR. This would explain why this works in release, but ESR is still unhappy. We don't anticipate CBCS streams occurring in the wild outside of test media at the moment and the new ESR (68) will have better support. Marking as WONTFIX based on that. However, I'm still interested if we're seeing intermittent fails, and what happens when we don't fail, as I would expect this to be a consistent failure path.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX

(In reply to Bryce Seager van Dyk (:bryce) from comment #4)

I've just tested and I see a consistent fail on Windows. I would expect this to fail on all platforms for ESR -- when it doesn't error, does playback work?

Yes, it did work. For me it was 1 out of ~10 attempts that the playback worked.

You need to log in before you can comment on or make changes to this bug.