Closed Bug 1563581 Opened 3 months ago Closed 3 months ago

"Failed to parse recommendation:" warning in console when a temporary add-on is installed.

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox69 --- verified

People

(Reporter: robwu, Assigned: robwu)

References

Details

Attachments

(1 file)

STR:

  1. Visit about:debugging and load any add-on as temporary.
  2. Open the global JS console, and look at the output:

Expected:

  • No warnings

Actual:

  • On Linux and macOS, the following warning is displayed:
1562263195585	addons.xpi	WARN	Failed to parse recommendation: {"operation":"open","path":"/path/to/extension/mozilla-recommendation.json","unixErrno":2}
  • On Windows, the following warning is displayed:
1562264673947	addons.xpi	WARN	Failed to parse recommendation: {"operation":"open","path":"C:\\path\\to\\extension\\mozilla-recommendation.json","winLastError":2}

Temporary add-ons were already ignored by the isRecommended getter of
`AddonWrapper, but they were still read and parsed, and consequently
resulted in unnecessary warning messages in the console.

This patch stops with warning about IO errors (because those are
expected for the majority of cases), and only logs a warning if there is
an actual parser error.

Duplicate of this bug: 1563590

p1 only due to patch being done.

Priority: -- → P1
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/b17959ee9a29
Remove redundant log warning when add-on is loaded r=mixedpuppy,kmag
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Verified as fixed in Ubuntu 14.0.4 and MacOS 10.14.1 using FF70.0a1 (20190710215049) and FF69.0b3 using the steps from the first comment.
No error messages or warning have been observed when temporary loading different add-ons.

Marking bug as verified fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.