Noted URL Doesn't Display Fully

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: jbucata, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623
Debian/1.0.0-0.woody.1
BuildID:    Mozilla 1.0.0

The page at the noted URL doesn't fully display.  It stops immediately after the
text: "Structurally, these are quite similar. But the tree walker involves some
system programming details, while the sequence generator involves".

View Source shows nothing after that point--not even closing tags or such like.

My Netscape 4.7x at work stops at exactly the same place.  IE5 at work stops at
an earlier point, which varies each time I exit and relaunch to try to view it.

I know the full text is there and available via HTTP, because I can see it
through other sites.  At work today I managed to finish reading it through an
Elmer Fudd filter, which seemed to be the easiest to get real English meaning
from.  (I nevew thought I'd evew use fiwtews wike this as a netwowk debugging
toow...)  Searching for a suitably large chunk of text in Google finds it there,
and Google's cached copy of the page displays just fine.  (Wish I'd thought of
that earlier today, with or without my other creative workaround.)










Reproducible: Always
Steps to Reproduce:
Visit page at noted URL


Actual Results:  Page is displayed truncated


Expected Results:  Displayed the entire page

Comment 1

17 years ago
I see the with linux build 20020708
tried http 1.0, no pipelining and no keep-alive.  nothing helped.

lynx and wget manage to get the full page and Mozilla has no problem displaying
it locally.

marking NEW
==> Http
Assignee: attinasi → darin
Component: Layout → Networking: HTTP
QA Contact: petersen → tever

Comment 2

17 years ago
marking NEW for real.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Created attachment 90576 [details]
nsHttp:5 NSPR log
(Assignee)

Comment 4

16 years ago
sounds like a server bug to me.  from the log file, i see that the server sends
a connection: close, which means that it is going to close the socket to
indicate the end of the file.  server bug IMO, marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 5

16 years ago
reopening, INVALID is a better resolution.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 6

16 years ago
marking INVALID
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 7

16 years ago
VERIFIED: invalid
Status: RESOLVED → VERIFIED
QA Contact: tever → httpqa
You need to log in before you can comment on or make changes to this bug.