Closed Bug 1563920 Opened 3 months ago Closed 3 months ago

Not possible to define filters for news server after bug 1542715

Categories

(Thunderbird :: General, defect, major)

defect
Not set
major

Tracking

(thunderbird68+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird68 + fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: aceman, Assigned: khushil324)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

In the Filter list dialog, in the top menulist you select for which account/server you want to define filters. For news (NNTP) servers, there is a submenu in which you can select a specific newsgroup on that server or the server itself (to define filters valid for all newsgroups).

The server item is no longer in the list, after bug 1542715.
This regresses functionality and also users can't see/edit the filters they already have defined on the server level.

If you do not have any newsgroups subscribed for a news server, you can choose the server in the menulist as there is no submenu. But if you have newsgroups, those are shown, but server name is no longer clickable and it is also not offered in the submenu, as before.

Summary: Not possible to define filters for news server → Not possible to define filters for news server after bug 1542715

Please address this asap since we're shipping our final beta next week.

Flags: needinfo?(khushil324)
Assignee: nobody → khushil324
Flags: needinfo?(khushil324)
Status: NEW → ASSIGNED

Thanks, the three content policy failures in the try run are already fixed.

Comment on attachment 9076751 [details] [diff] [review]
Bug-1563920_fixed-news-server-filters.patch

Let's not forget this for TB 68 beta, which is now in "release". I'll use the release flag for now to distinguish from TB 69 beta. What a mess.
Attachment #9076751 - Flags: approval-comm-release+
Target Milestone: --- → Thunderbird 70.0
Attachment #9076751 - Flags: approval-comm-beta+
Comment on attachment 9076751 [details] [diff] [review]
Bug-1563920_fixed-news-server-filters.patch

Review of attachment 9076751 [details] [diff] [review]:
-----------------------------------------------------------------

Great, thank you.
Attachment #9076751 - Flags: review?(acelists) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/566906807461
fixed defining filters for news server. r=aceman

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #9076751 - Flags: approval-comm-release+
You need to log in before you can comment on or make changes to this bug.