Closed Bug 1564021 Opened 4 months ago Closed 4 months ago

Treat viewport meta tag as an empty tag if there is no valid content

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1556275 +++

The site reported in https://webcompat.com/issues/31296 has <meta name="viewport" content="1200“ /> and the meta viewport is invalid so we should treat it as ViewportType::Empty.

Pushed by hikezoe.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b98bc3c506d
Use the default desktop width (980px) in the case where we have any viewport meta element but no valid content there. r=botond
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → hikezoe.birchill

Is this something which should be considered for backport?

Flags: needinfo?(hikezoe.birchill)
Flags: in-testsuite+

Comment on attachment 9076658 [details]
Bug 1564021 - Use the default desktop width (980px) in the case where we have any viewport meta element but no valid content there. r?botond

Beta/Release Uplift Approval Request

  • User impact if declined: User will see some sites are rendered in an unexpected narrow device width so that font-sizes in the contents might be tremendously bigger than expected or some images gets smaller than expected
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: 1564021 (already uplifted)
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is basically trivial, it shouldn't cause any critical issue.
  • String changes made/needed: None

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: On mobile this is also an important fix which was a fallout from bug 1500314
  • User impact if declined: Same as above
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Same as above
  • String or UUID changes made by this patch: None
Flags: needinfo?(hikezoe.birchill)
Attachment #9076658 - Flags: approval-mozilla-esr68?
Attachment #9076658 - Flags: approval-mozilla-beta?

(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)

Is this something which should be considered for backport?

Unfortunately yes. I found https://webcompat.com/issues/34891 which is caused by this, there might be other webcompat issues I am not aware of, and of course there are more sites affected by this in the wild.

Comment on attachment 9076658 [details]
Bug 1564021 - Use the default desktop width (980px) in the case where we have any viewport meta element but no valid content there. r?botond

Fixes some mobile web compat regressions. Approved for GV69 and Fennec 68.1b3.

Attachment #9076658 - Flags: approval-mozilla-esr68?
Attachment #9076658 - Flags: approval-mozilla-esr68+
Attachment #9076658 - Flags: approval-mozilla-beta?
Attachment #9076658 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.