Closed Bug 1564072 Opened 5 months ago Closed 5 months ago

Track more uses of malloc memory precisely

Categories

(Core :: JavaScript: GC, task, P1)

task

Tracking

()

RESOLVED FIXED

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(4 files)

Following on from bug 1395509, continue to add tracking for malloc memory owned by GC things.

Priority: -- → P1
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/03e0de747d02
Track malloc memory used by debugger objects r=jimb
https://hg.mozilla.org/integration/mozilla-inbound/rev/52d045b1e2f5
Allow ZoneAllocPolicy to be moved r=sfink
https://hg.mozilla.org/integration/mozilla-inbound/rev/ea7110a75916
Track memory used by some ctypes data structures r=sfink

The memory tracking needs the GC thing so I made WasmBreakpointSite hold a pointer to the Instance rather than just the DebugState. I added DebugState::getBreakpointSite for cases were we already expect this to exist, like JSScript::getBreakpointSite.

This replaces SystemAllocPolicy with ZoneAllocPolicy for things related to zones where possible. There are a few places where this isn't possible at the moment due to header include order. I'll try and revisit these later after removing the current malloc memory tracking as this simplifies the situation.

Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7631a5be1dd9
Associate more per-zone memory with the zone r=sfink
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/02fb177c82e8
Track malloc memory used by WasmBreakpoingSites r=luke
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e092bce453c
Track malloc memory used by Breakpoints r=jimb
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7faeed8fec2
Deprecate FreeOp APIs that don't track memory and rename them to make their use obvious r=sfink

(In reply to Cristian Brindusan [:cbrindusan] from comment #10)
Looks like I removed a #include while merging updates, sorry about that.

Flags: needinfo?(jcoppeard)
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a484748a625
Track malloc memory used by WasmBreakpoingSites r=luke
https://hg.mozilla.org/integration/mozilla-inbound/rev/caf4b46a3fc4
Track malloc memory used by Breakpoints r=jimb
https://hg.mozilla.org/integration/mozilla-inbound/rev/88bacba58490
Deprecate FreeOp APIs that don't track memory and rename them to make their use obvious r=sfink
Regressions: 1565275
Status: REOPENED → ASSIGNED
Target Milestone: mozilla70 → ---
Status: ASSIGNED → RESOLVED
Closed: 5 months ago5 months ago
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.